Bug 92676 - before file change notification
before file change notification
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Filesystems
5.x
All All
: P2 (vote)
: 6.x
Assigned To: rmatous
issues@platform
: API, API_REVIEW_FAST
Depends on:
Blocks: 92671
  Show dependency treegraph
 
Reported: 2007-01-17 11:15 UTC by Tomas Stupka
Modified: 2008-12-22 11:21 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
to review (7.68 KB, patch)
2007-02-09 11:56 UTC, rmatous
Details | Diff
final diff for review including entry in API changes (10.10 KB, patch)
2007-02-09 12:14 UTC, rmatous
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Stupka 2007-01-17 11:15:29 UTC
all events related to a file change are comming ex post - after the change has
happened. the problem is that the local history needs to be notified already
when a file is going to be changed  and not just after it. see also issue #90924
and Y07 in issue #91280.
Comment 1 rmatous 2007-02-09 11:56:17 UTC
Created attachment 38285 [details]
to review
Comment 2 rmatous 2007-02-09 12:14:20 UTC
Created attachment 38288 [details]
final diff for review including entry in API changes
Comment 3 rmatous 2007-02-09 12:15:37 UTC
For Tomas: slightly modified (parameter File->FileObject) to keep it consistent
with other methods.
Comment 4 rmatous 2007-02-09 12:18:24 UTC
This is very tiny friend api change, Tomas noded that it works, so I'm going to
integrate it on monday if there are no objections.
Comment 5 Jesse Glick 2007-02-10 21:46:16 UTC
Missing @since. Otherwise looks reasonable to me.
Comment 6 rmatous 2007-02-12 10:43:20 UTC
@since added and integrated.

/cvs/openide/masterfs/manifest.mf,v  <--  manifest.mf
new revision: 1.16; previous revision: 1.15

/cvs/openide/masterfs/apichanges.xml,v  <--  apichanges.xml
new revision: 1.6; previous revision: 1.5

/cvs/openide/masterfs/test/unit/src/org/netbeans/modules/masterfs/providers/ProvidedExtensionsTest.java,v
 new revision: 1.5; previous revision: 1.4

/cvs/openide/masterfs/src/org/netbeans/modules/masterfs/providers/ProvidedExtensions.java,v
 new revision: 1.5; previous revision: 1.4

/cvs/openide/masterfs/src/org/netbeans/modules/masterfs/MasterFileObject.java,v
 new revision: 1.61; previous revision: 1.60

/cvs/openide/masterfs/src/org/netbeans/modules/masterfs/ProvidedExtensionsProxy.java,v
 new revision: 1.5; previous revision: 1.4

/cvs/openide/masterfs/src/org/netbeans/modules/masterfs/filebasedfs/fileobjects/FileObj.java,v
 new revision: 1.23; previous revision: 1.22
Comment 7 rmatous 2007-02-15 09:47:05 UTC
Fixed


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo