Bug 91187 - the code window focuslosting
the code window focuslosting
Status: RESOLVED FIXED
Product: editor
Classification: Unclassified
Component: Completion & Templates
5.x
All Windows XP
: P1 (vote)
: TBD
Assigned To: Dusan Balek
issues@editor
: FOCUS
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-18 11:31 UTC by sridher
Modified: 2007-11-05 13:38 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Thsi is a screenshot how error occurs (128.68 KB, image/png)
2006-12-18 11:42 UTC, sridher
Details
attaching messages.log (37.35 KB, text/plain)
2006-12-21 06:17 UTC, sridher
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sridher 2006-12-18 11:31:39 UTC
editor focus losing when pressing the dot(properties window not waiting and
focus gone unknown place) in keyboard.
and this problem occurs in some machines, some are not. in some machines under
one user it will working fine,but not in other user(Might be user specific
settings are corrupting ). I think of virus and spam i installed anti virus,
anti spam softwares the problem same. some times the properties window waiting
but most of the times not.

we have Windows XP sp2 the same problem in Netbeans5.5,Netbeans5.0 to. (I tested
it in 10 machines)
Comment 1 sridher 2006-12-18 11:42:58 UTC
Created attachment 36728 [details]
Thsi is a screenshot how error occurs
Comment 2 Miloslav Metelka 2006-12-18 17:04:48 UTC
Please download and run KeyEventDebug.jar at
http://editor.netbeans.org/servlets/ProjectDocumentList and check whether it
works in the same way.
Comment 3 Miloslav Metelka 2006-12-18 17:09:58 UTC
One more question: does it *only* happen when you press '.' in java sources?
What if you would create a plain-text file and type '.' in it?
If it is specific to java sources after pressing '.' then it's probably related
to the way how the javax.swing.PopupFactory creates popups on your environment.
Please describe any specifics e.g. residental apps/windows if any that might be
related to this. Thanks.
Comment 4 sridher 2006-12-19 08:02:01 UTC
1. for the plain text files it is working fine. but the java source files not.
2. I tested KeyEventDebug.jar thats working fine.
3. after closing all application(java) we are running the netbeans, no difference.
Comment 5 Miloslav Metelka 2006-12-20 13:35:10 UTC
Can you please attach your messages.log to see the JDK version and possibly any
exceptions that were thrown? Thanks.
Comment 6 sridher 2006-12-21 06:17:49 UTC
Created attachment 36872 [details]
attaching messages.log
Comment 7 sridher 2006-12-21 12:15:03 UTC
when changing the line netbeans_jdkhome="C:\Program Files\Java\jdk1.5.0_05" in
the file 'netbeans.conf' working fine. might be some of the versions are not
supported by netbeans ex: my previous version: jdk1.6.0-ea-b41.

but i couldn't remember old versions of java that are making one user access
other not

is the problem with jdk or netbeans ?

    if jdk can we leave this issue.
Comment 8 sridher 2006-12-29 07:07:50 UTC
the problem is appearing at java-ea side. this is not an netbeans issue.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo