Bug 9115 - The relative path does not work in <jsp:include
The relative path does not work in <jsp:include
Status: CLOSED WONTFIX
Product: javaee
Classification: Unclassified
Component: Code
3.x
PC Windows ME/2000
: P1 (vote)
: TBD
Assigned To: issues@javaee
issues@javaee
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-16 15:19 UTC by Petr Pisl
Modified: 2002-07-19 15:28 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Pisl 2001-01-16 15:19:06 UTC
Given these files:

util/foo.jsp common/goo.jsp

And this code:

[somewhere in foo.jsp] <jsp:include page="../common/goo.jsp" flush="true"/>

In Boston:
Will result in a 'Included Servlet Error: 500...' error?

In Netbeans #104:
Compilation of the requested JSP page failed. Please see compilation errors in
the Output Window

And it is in Output Window:
 [-1:-1] Your web module does not contain file
C:\Forte\netbeans\Development\common\goo.jsp

-- but this file exists

The problem is too, that it works in F4J 1.0 and our customers, who developed
their applications in F4J 1.0 can not work in F4J 2.0.
Comment 1 Petr Jiricka 2001-01-18 15:38:59 UTC
Fixed in the trunk: 18-Jan-2001. The fix is that if the compilation mechnism
which calls the IDE fails for some reason, use the compiler built-in in Tomcat.

Still needs to be fixed in Boston, as this bug is serious enough to be fixed in
the released product.
Comment 2 Petr Pisl 2001-01-23 12:28:59 UTC
Fixed in Boston (FFJ 2.0) JP1.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo