Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 91005 - Deadlock when adding JSF framework
Deadlock when adding JSF framework
Status: VERIFIED FIXED
Product: javaee
Classification: Unclassified
Component: JSF
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Petr Pisl
issues@javaee
:
: 99547 (view as bug list)
Depends on:
Blocks: 92999
  Show dependency treegraph
 
Reported: 2006-12-13 09:26 UTC by Jiri Skrivanek
Modified: 2007-04-23 12:33 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Thread dump (17.73 KB, text/plain)
2006-12-13 09:27 UTC, Jiri Skrivanek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Skrivanek 2006-12-13 09:26:26 UTC
I have experienced a deadlock while I was adding JSF framework to regular web
project. To reproduce:

- create a web application without any framework
- open Project Properties dialog and select Frameworks category
- click Add button
- select JavaServer Faces and confirm the dialog
- uncheck Validate XML and check Verify Objects check boxes (not sure if this is
required to make a deadlock but very probably yes)
- click OK to confirm Project Properties dialog

Build 20061212-2258, JDK1.5.0_10, WindowsXP.
Comment 1 Jiri Skrivanek 2006-12-13 09:27:17 UTC
Created attachment 36632 [details]
Thread dump
Comment 2 Jiri Skrivanek 2006-12-13 09:30:31 UTC
I forgot to say that it doesn't happen every time. But if you repeat described
scenario several times it happens for sure.
Comment 3 Petr Pisl 2007-04-19 14:37:48 UTC
Fixed in the trunk.
Checking in ConfFilesNodeFactory.java;
/cvs/web/project/src/org/netbeans/modules/web/project/ui/ConfFilesNodeFactory.java,v
 <--  ConfFilesNodeFactory.java
new revision: 1.3; previous revision: 1.2
done
Comment 4 Petr Pisl 2007-04-19 14:47:13 UTC
*** Issue 99547 has been marked as a duplicate of this issue. ***
Comment 5 Jiri Skrivanek 2007-04-23 12:33:00 UTC
Verified.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo