Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 90981 - [cc] annotation attribute values completion doesn't work
[cc] annotation attribute values completion doesn't work
Status: VERIFIED FIXED
Product: java
Classification: Unclassified
Component: Editor
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Dusan Balek
issues@java
: REGRESSION
Depends on:
Blocks: 92999
  Show dependency treegraph
 
Reported: 2006-12-12 18:57 UTC by Jindrich Sedek
Modified: 2007-04-18 13:51 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jindrich Sedek 2006-12-12 18:57:00 UTC
Create WebApplication
create new java class
type this somewhere into class body
    @Column(nullable=|true)
    int i;
add import
press Ctrl+Space at possition of "|" true, false should be offered, but just
some classes and packages rises
Comment 1 Jindrich Sedek 2007-02-06 12:11:34 UTC
increasing priority since it blocks running automatic functional tests for j2ee
editor
Comment 2 Marek Fukala 2007-02-16 15:02:37 UTC
Erno is now supposedly owner of the custom j2ee java annotation completions.
Comment 3 Erno Mononen 2007-02-16 15:22:46 UTC
Passing to java/editor since I don't see anything custom or j2ee specific here.
Comment 4 Dusan Balek 2007-02-16 19:29:56 UTC
Fixed.

Checking in JavaCompletionProvider.java;
/cvs/java/editor/src/org/netbeans/modules/editor/java/JavaCompletionProvider.java,v
 <--  JavaCompletionProvider.java
new revision: 1.89; previous revision: 1.88
done
Comment 5 Jindrich Sedek 2007-02-21 13:13:01 UTC
This issue is not well fixed. Code completion offers true and false values, but
it  doesn't offer the rest of values for other annotations

example:
@WebParam(mode=|) should offer all WebParam.Mode values as IN, OUT, INOUT

@Basic(fetch=|) should offer all javax.persistance.FetchTypes as EAGER, LAZY
Comment 6 Dusan Balek 2007-03-20 10:15:12 UTC
Fixed. See JavaCompletionProvider.java revision 1.99.
Comment 7 Jindrich Sedek 2007-04-18 13:51:46 UTC
Verified NetBeans IDE Dev 200704170800


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo