Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 90571 - Stop correcting files permissions and removing irrelevant files
Stop correcting files permissions and removing irrelevant files
Status: VERIFIED FIXED
Product: installer
Classification: Unclassified
Component: NBI
6.x
All Windows XP
: P2 (vote)
: 6.x
Assigned To: Kirill Sorokin
issues@installer
:
: 105497 105609 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-05 10:59 UTC by Kirill Sorokin
Modified: 2008-03-11 12:24 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kirill Sorokin 2006-12-05 10:59:47 UTC
An unexpected use-case was described - installation goes on a linux machine,
while the product will be used from windows via samba, thus removing
windows-related files would hurt the user experience.

The files permissions, should be the same as in the original product zip file,
thus they should be read from the created metadata, instead of the engine trying
to guess which is correct.
Comment 1 dlipin 2007-06-04 16:40:34 UTC
*** Issue 105609 has been marked as a duplicate of this issue. ***
Comment 2 Michal Zlamal 2007-06-04 17:29:09 UTC
Changing to P2 defect because it seriously affects ability to use NB on unixes
to generate an NB platform application for windows - it is impossible.
Comment 3 dlipin 2007-06-07 08:08:19 UTC
*** Issue 105497 has been marked as a duplicate of this issue. ***
Comment 4 Jesse Glick 2007-06-07 19:38:58 UTC
In particular, files in the harness/ cluster must NOT be removed, as they are
destined for use in applications built by the user which must be cross-platform.
Comment 5 Kirill Sorokin 2007-06-14 09:14:45 UTC
I've disabled removing files irrelevant to the current platform in all netbeans components. The issue is not yet
completely closed as we need to resolve the files permissions part of it. So far the current behavior harmless, but not
exactly "proper".
Comment 6 Kirill Sorokin 2007-07-09 15:44:19 UTC
Since Dima has implemented the native chmod call, we can safely restore the original files permissions without much
worrying about performance.
Comment 7 Kirill Sorokin 2007-07-09 19:07:16 UTC
-> FIXED
Comment 8 Kirill Sorokin 2008-03-11 12:24:53 UTC
Verifying installer issues.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo