Bug 90112 - Not able to generate JSR172 Client Midlet when space in path of the project
Not able to generate JSR172 Client Midlet when space in path of the project
Status: VERIFIED FIXED
Product: javame
Classification: Unclassified
Component: Web Services
5.x
All All
: P2 (vote)
: 6.x
Assigned To: Michal Skvor
issues@mobility
: SPACE_IN_PATH
: 103513 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-27 21:48 UTC by pcmreddy
Modified: 2007-09-01 13:47 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pcmreddy 2006-11-27 21:48:58 UTC
NB 5.5 + Mobility module for NB 5.5 with JDK 1.6.0-rc on XP (with all latest
updates)

File -> New -> Mobile -> Mobile Application
Accept all defaults
Select MobileApplication in Projects Tab
uncheck option "Create Hello MIDlet"
Right click select New -> J2ME Web Service Client
set WSDL URL to :
http://www.swanandmokashi.com/HomePage/WebServices/StockQuotes.asmx?WSDL
Click on Retrieve WSDL Button
Click on Finish button

Observe there is no midlet generated.
There are only two files are generated. "StockQuotes.wsclient" and
"StockQuotes.asmx.wsdl"

The same thing works fine with "JDK 1.5.0_09"
Comment 1 Lukas Hasik 2007-03-01 13:11:52 UTC
it's strange. The WTK doesn't generate the stubs when you are running it from
JSR172 wizard.  However when you are running WTK on jdk1.6 and use the action
Generate Stubs then it works.

Therefore it's probably problem on MobPack side - needs more investigation. 
This issue could be 5.5.1_candidate
Comment 2 Michal Skvor 2007-03-06 13:28:41 UTC
WTK has problems with generation of stub on path which contains space character.
The solution is to not generate stubs on such path.
Comment 3 Lukas Hasik 2007-04-03 09:14:27 UTC
RELNOTE: The stubs of JSR 172 will not be generated when the project is at path
with a space *and* you are running the NetBeans on JDK 1.6. It is a problem of
the Wireless Toolkit 2.2 stub generator.

WORKAROUND: Run the NetBeans on JDK 1.5
Comment 4 Lukas Hasik 2007-04-23 17:27:54 UTC
MP doesn't use WTK generator (see issue 102177). It means that it HAS to be
fixed on our side.
Please fix the issue with the space in path.
Comment 5 Lukas Hasik 2007-04-23 17:45:39 UTC
works in the 6.0
Comment 6 Lukas Hasik 2007-04-25 10:43:53 UTC
CC'ing Petr maybe he knows where are the missing quotes ;)
Comment 7 pcmreddy 2007-04-25 20:13:45 UTC
I tried to create the same project in folder with out spaces.
NetBeans is not generating Visual Midlet Client automatically.
Comment 8 Lukas Hasik 2007-05-09 18:05:58 UTC
*** Issue 103513 has been marked as a duplicate of this issue. ***
Comment 9 Michal Skvor 2007-07-16 10:29:22 UTC
It's fixed in 6.0.
Comment 10 Lukas Hasik 2007-08-24 15:27:39 UTC
it generates the stubs. Sample midlet isn't generated
Comment 11 jinb 2007-09-01 13:47:20 UTC
As far as backport/fix of this issue in NB551 requires much resources, it was decided to don't backport/fix it in
release551_fixes branch.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo