Bug 89806 - I18N: Create operation for webservice unsuccessfully in zh locale, ide hangs up
I18N: Create operation for webservice unsuccessfully in zh locale, ide hangs up
Status: CLOSED FIXED
Product: nblocalization
Classification: Unclassified
Component: Code
5.x
All All
: P1 (vote)
: TBD
Assigned To: Rebecca Liu
issues@nblocalization
: I18N
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-22 07:09 UTC by Will Zhang
Modified: 2006-11-27 06:39 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Will Zhang 2006-11-22 07:09:53 UTC
nbbuild200611220100
reproduce:
Step 1: First create a EJB project. Name the project Hello.
Step 2: Now invoke the new Web Service wizard. Name the web service Hello.
Step 3: Add an operation to the web service.

result:
ide hangs up
This bug only happen in zh locale
Comment 1 Masaki Katakai 2006-11-22 07:35:38 UTC
It seems that "operation" is translated into Chinese,

http://www.netbeans.org/issues/show_bug.cgi?id=88367

Rebecca, could you check this bug and revert back to English?

Comment 2 Rebecca Liu 2006-11-22 17:14:56 UTC
Found two files containing: TXT_DefaultOperationName=operation

websvc/core/src/org/netbeans/modules/websvc/core/webservices/action/Bundle.properties
In this file, it is like:
# Note: TXT_DefaultOperationName must be valid Java identifier name
#NOI18N
TXT_DefaultOperationName=operation
So "operation" was not translated.

websvc/core/src/org/netbeans/modules/websvc/core/jaxws/actions/Bundle.properties
In this file, there is no "#NOI18N". Then the string "operation" was translated
to Chinese. I guess the problem occured because of this. Please add such
"#NOI18N" comment before that.

Anyway, I will change the second one back to English.
Comment 3 Will Zhang 2006-11-27 06:33:18 UTC
verified and fixed in build20061125


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo