Bug 89651 - Cannot connect to Oracle database
Cannot connect to Oracle database
Status: VERIFIED FIXED
Product: db
Classification: Unclassified
Component: Code
6.x
PC Windows XP
: P1 (vote)
: 6.x
Assigned To: Andrei Badea
issues@db
:
Depends on:
Blocks: 89637
  Show dependency treegraph
 
Reported: 2006-11-20 11:28 UTC by Jiri Skrivanek
Modified: 2006-11-23 11:11 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Skrivanek 2006-11-20 11:28:36 UTC
I am not able to connect to Oracle database. I am using ojdbc14-10.2.jar, build
20061120-0123, JDK1.5.0_09, WindowsXP. I can send you URL in personal email if
you wish but the same works in NB5.5 and doesn't work in NB6.0. Error messages
is here:

INFO: Io exception: The Network Adapter could not establish the connection
java.sql.SQLException: Io exception: The Network Adapter could not establish the
connection
        at
oracle.jdbc.driver.DatabaseError.throwSqlException(DatabaseError.java:112)
        at
oracle.jdbc.driver.DatabaseError.throwSqlException(DatabaseError.java:146)
        at
oracle.jdbc.driver.DatabaseError.throwSqlException(DatabaseError.java:255)
        at oracle.jdbc.driver.T4CConnection.logon(T4CConnection.java:387)
        at oracle.jdbc.driver.PhysicalConnection.<init>(PhysicalConnection.java:420)
        at oracle.jdbc.driver.T4CConnection.<init>(T4CConnection.java:165)
        at
oracle.jdbc.driver.T4CDriverExtension.getConnection(T4CDriverExtension.java:35)
        at oracle.jdbc.driver.OracleDriver.connect(OracleDriver.java:801)
        at
org.netbeans.modules.db.explorer.DbDriverManager.getConnection(DbDriverManager.java:99)
[catch] at
org.netbeans.modules.db.explorer.DatabaseConnection$2.run(DatabaseConnection.java:500)
        at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:541)
        at
org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:963)
Comment 1 Andrei Badea 2006-11-20 11:46:14 UTC
Seems caused by issue 85270. As a workaround set the proxy to No Proxy in
Options - General, or add the host to which you are connecting to the list of no
proxy hosts.
Comment 2 Martin Schovanek 2006-11-21 17:06:56 UTC
NB 6.0 M5 stopper.
Comment 3 Andrei Badea 2006-11-22 12:47:32 UTC
Jirka Rechtacek says it should be fixed already; can't reproduce it anymore in
today's build.
Comment 4 Jiri Skrivanek 2006-11-23 11:11:09 UTC
Verified.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo