Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 89648 - Code model memory consumption shouldn't depend linearly on project size
Code model memory consumption shouldn't depend linearly on project size
Status: RESOLVED WONTFIX
Product: cnd
Classification: Unclassified
Component: Code Model
5.x
All All
: P3 (vote)
: 6.x
Assigned To: Vladimir Kvashin
issues@cnd
other
:
Depends on: 91546
Blocks: 123872
  Show dependency treegraph
 
Reported: 2006-11-20 10:46 UTC by Vladimir Kvashin
Modified: 2012-07-31 12:23 UTC (History)
0 users

See Also:
Issue Type: TASK
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Kvashin 2006-11-20 10:46:17 UTC
Now code model consumes a lot of memory. And even if we reduce memory consumtion
twice - or thrice - it won't help. If user creates project that is large enough,
he'll finally get OutOfMemoryError.

The problem is in the code model implementation design - it's too monolitic now;
objects hard reference other objects, so the entire model should necessarily
reside in memory.

Code model implementation should be redesign so that the entire model won't
reside necessarily in memory.
Comment 1 Jesse Grodnik 2006-11-28 23:28:10 UTC
Default setting for tasks is P3.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo