Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 89334 - wrong return code printed when using new io terminal window
wrong return code printed when using new io terminal window
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: -- Other --
5.x
All All
: P2 (vote)
: 6.x
Assigned To: _ gordonp
issues@cnd
:
: 89782 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-14 22:00 UTC by Thomas Preisler
Modified: 2008-01-23 17:11 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Preisler 2006-11-14 22:00:26 UTC
The build window used to display the return code of the application and print
something like "Failed. Return code = 5" when the application failed (returned
something different than 0). Now it always says "Succeeded. Return code = 0"
because it probably displays the return code of the start command and not the
application. If you switch to internal window, it works as expected.
Comment 1 soldatov 2006-11-21 08:11:19 UTC
When I run a C++ program that's cause an exception, then gnome-terminal appears
with '/opt/netbeans-5.5/cnd1/bin/dorun.sh: line 38: 12479 Aborted              
  "$pgm" "$@" [Press Enter to close window]' message. But I think, user expects
'program terminated' or other same message in this case.
When I press 'Enter' then 'Run successful. Exit value 0.' message appears.

I used this code:
------------------------------
int main() {
       throw 1;
       return 0;
}

------------------------------ 
Comment 2 _ gordonp 2006-11-28 19:49:02 UTC
*** Issue 89782 has been marked as a duplicate of this issue. ***
Comment 3 _ gordonp 2007-02-08 00:38:24 UTC
Fixed
Comment 4 Alexander Ioffe 2008-01-23 17:11:44 UTC
Verified in build 20080117


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo