Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 88446 - Ability to drag-n-drop into watch window
Ability to drag-n-drop into watch window
Status: CLOSED DUPLICATE of bug 44575
Product: debugger
Classification: Unclassified
Component: Code
6.x
PC Windows XP
: P3 (vote)
: 6.x
Assigned To: issues@debugger
issues@debugger
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-01 18:22 UTC by _ gtzabari
Modified: 2008-04-15 18:42 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description _ gtzabari 2006-11-01 18:22:56 UTC
I'm surprised no one else seemed to suggest this before but I would love to see
Netbeans' watch window emulate Visual Studio's watch window more. Specifically,
you should be able to:

- Select, drag and drop text from the editor window into the watch window
- Add a new watch simply by clicking in an empty "slot" (one should always be
visible at the bottom) and typing the new expression

I find the existing interface very kludgey. I hate having to bring up a dialog
just to add a new watch. I should be able to just type it in directly or
drag-n-drop.
Comment 1 Martin Entlicher 2006-11-02 09:36:32 UTC
We have this suggestion for a long time already - see issue #44575. I agree that
this would much improve the usability.

*** This issue has been marked as a duplicate of 44575 ***
Comment 2 Petr Cyhelsky 2008-04-15 18:41:40 UTC
verified duplicate


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo