Bug 86857 - Error In Database Explorer -- "Tables" view
Error In Database Explorer -- "Tables" view
Status: RESOLVED DUPLICATE of bug 84654
Product: db
Classification: Unclassified
Component: Code
5.x
All Windows XP
: P1 (vote)
: 5.x
Assigned To: Andrei Badea
issues@db
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-10 14:12 UTC by asleson
Modified: 2006-10-10 15:23 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description asleson 2006-10-10 14:12:05 UTC
NetBeans 200609270000
JDK 1.6 build 101
Windows XP

I connect to an Oracle 9i database using the Oracle thin driver.  It connects
OK, and I can issue SQL statements against the database, but when I try to open
the "Tables" view I get an error that says "Unable to read the database
structure, connection is broken; Unsupported feature".  This worked great in
NetBeans 5.0 RC1.  So, I can't see a list of the tables in the schema.

Oracle driver:  oracle.jdbc.driver.OracleDriver  (from classes12.jar)
URL:  jdbc:oracle:thin:@localhost:1521:mydatabase

Here's the entry from the log file:

INFORMATIONAL *********** Exception occurred ************ at 8:06 AM on Oct 10, 2006
org.netbeans.api.db.explorer.DatabaseException: Unsupported feature
	at
org.netbeans.modules.db.explorer.infos.TableListNodeInfo.initChildren(TableListNodeInfo.java:75)
	at
org.netbeans.modules.db.explorer.infos.DatabaseNodeInfo.getChildren(DatabaseNodeInfo.java:675)
[catch] at
org.netbeans.modules.db.explorer.DatabaseNodeChildren$2.run(DatabaseNodeChildren.java:94)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:499)
	at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:932)
Caused by: java.sql.SQLException: Unsupported feature
	at oracle.jdbc.dbaccess.DBError.throwSqlException(DBError.java:134)
	at oracle.jdbc.dbaccess.DBError.throwSqlException(DBError.java:179)
	at oracle.jdbc.dbaccess.DBError.throwSqlException(DBError.java:269)
	at
oracle.jdbc.dbaccess.DBError.throwUnsupportedFeatureSqlException(DBError.java:689)
	at
oracle.jdbc.OracleDatabaseMetaData.getDatabaseMajorVersion(OracleDatabaseMetaData.java:4442)
	at
org.netbeans.lib.ddl.adaptors.DefaultAdaptor.getDatabaseMajorVersion(DefaultAdaptor.java:3967)
	at
org.netbeans.modules.db.explorer.infos.TableListNodeInfo.initChildren(TableListNodeInfo.java:49)
	... 4 more
Comment 1 Andrei Badea 2006-10-10 15:23:15 UTC
Probably caused by an old version of the Oracle driver, please use a 10.2.x
driver instead.

*** This issue has been marked as a duplicate of 84654 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo