Bug 86753 - Window focus changed after closing any dialog.
Window focus changed after closing any dialog.
Status: VERIFIED WORKSFORME
Product: platform
Classification: Unclassified
Component: Window System
5.x
Sun Solaris
: P3 (vote)
: 6.x
Assigned To: David Simonek
issues@platform
: FOCUS, RANDOM
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-09 09:03 UTC by novakm
Modified: 2008-12-22 14:36 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description novakm 2006-10-09 09:03:05 UTC
1) Invoke Find (CTRL+F default)
2) Close it
result: Focus is changed to another window on the same workspace (mozilla or
whatever)

Similar for Invoking CVS->Checkout->Cancel and for any new dialog in general. 

This issue appears probably only on CDE as with GNOME it was OK.
----------
  Product Version         = NetBeans 5.5 RC1 (Build 200610030000)
  Operating System        = SunOS version 5.9 running on sparc
  Java; VM; Vendor; Home  = 1.6.0-rc; Java HotSpot(TM) Client VM 1.6.0-rc-b99;
Sun Microsystems Inc.; /usr/jdk1.6.0/jre
  System Locale; Encoding = en_US (nb); ISO8859-1
----------
Comment 1 David Simonek 2006-10-09 10:49:36 UTC
Reporter, please test with SwingSet2 demo which comes with JDK. Also please try
to test with JDK 1.5.x.
It may be general JDK issue on specific window manager, not NetBeans directly.
Thanks.
Comment 2 David Simonek 2006-10-16 12:08:37 UTC
Any news, please? Current info isn't enough for us to identify or fix the issue.
Comment 3 novakm 2006-10-18 08:49:12 UTC
Sorry for not answering earlier. I tried the SwingSet2 you recommended, but I
didn't encounter any window focus switches. I tried to find a way how to
reproduce it, but without any success. 
  It happened several more times to me, but I wasn't able to find the reason. I
was testing CVS module following the test specifications on
http://qa.netbeans.org/modules/test-specs-55.html, so you can try it if it
happens to you as well. I had opened NB only on half of my screen and Mozilla
fullscreened bellow it so I could follow the instructions without switching focus.
Comment 4 David Simonek 2006-11-28 15:01:44 UTC
Nothing we can do on our side without more info and reproductible case, probably
OS window manager x JDK issue.
Comment 5 novakm 2007-10-30 09:19:51 UTC
Verified.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo