Bug 86751 - Could not set Tab in Makefile after opening Options.
Could not set Tab in Makefile after opening Options.
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: Editor
5.x
Sun All
: P3 (vote)
: 6.x
Assigned To: Thomas Preisler
issues@cnd
editor
:
: 76392 (view as bug list)
Depends on: 88167
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-09 08:40 UTC by alexandrov
Modified: 2008-03-19 19:00 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description alexandrov 2006-10-09 08:40:35 UTC
1. mkdir /export/home/tester/1
2. cd /export/home/tester/1
3. vi args.c
-----------------------------------------
#include <stdio.h>
#include <string.h>
#include <stdlib.h>

int main(int argc, char**argv) {
    int i;
    
    // Prints arguments
    printf("Arguments:\n");
    for (i = 0; i < argc; i++) {
        printf("%i: %s\n", i, argv[i]);
    }
    
    return 0;
}
-----------------------------------------

4. vi Makefile

---------------------------------
args: args.c
    gcc -g -o args args.c
----------------------------------

5. Clean userdir. Start Netbeans
6. New project with existing Makefile
6.1 Project Name and Location set default(project location is ~/MakefileProject1)
6.2 Build actions: choose Working directory: /export/home/tester/1
Build command: make
Output file: /export/home/tester/1/args
6.3 On "Source File Folders" add /export/home/tester/1
Click Finish.
7. Add Existing Item /export/home/tester/1/Makefile.
8. Build Project ==> Build failed due to "Makefile:2: *** missing separator. 
Stop.". It's Ok, we just need to replace leading spaces in 2-nd line of Makefile
with Tab.
9. Open Makefile in Editor. Set Tab instead of spaces. Build project ==> Build
successful.
10. Open Tools/Options and just push OK.
11. Try the step 9 again. I mean delete the Tab and set new Tab in the same
place. Instead of 8-spaces tab there is Tab expanded to 4 spaces. Build failed
again. Due to IZ 86750(pure Netbeans bug) I can't restore not expand Tabs to spaces.
So after user once open Options he could not add new commands to Makefile. I
think it is very serious bug and need in immediate attention
Comment 1 Maria Tishkova 2006-10-09 15:59:38 UTC
downgraded priority to P2 it is definitely not P1
Comment 2 Thomas Preisler 2006-10-10 17:57:21 UTC

*** This issue has been marked as a duplicate of 74541 ***
Comment 3 _ gordonp 2006-10-28 00:57:25 UTC
I probably shouldn't have called this a duplicate of 74541. Its close, but
not quite. Anyway, now that I've fixed 74541 there is a minor issue remaining,
which is closer to this issue than 74541. There is a bug in the Editor Library
module (88167) which make Makefiles ignore our tab settings and use the general
ones. Since the fix to 74541 ensures the 1st tab stays a tab, what you end up
with is a tab followed by either more tabs or spaces (the 1st tab appends 4
spaces, the 2nd changes them to a 2nd tab).

Of course, this is only after Tools->Options Editor Indentation has been
visited.

I'll reopen but change to a P3 since this is onl still an issue for 2nd and
later tabs. Its also blocked by 88167. Its probably really just a P4 now,
but I'll make it a P3 because the fix is so easy (I think). The expected fix
(once 88167 is fixed) is to remove MakefileFormatter.getIndentString().
Assuming Formatter.getIndentString() works correctly, tabs should display as
expected.
Comment 4 _ gordonp 2006-10-28 01:02:01 UTC
*** Issue 76392 has been marked as a duplicate of this issue. ***
Comment 5 Thomas Preisler 2008-03-19 18:21:20 UTC
I believe this is not an issue anymore. At least I cannot reproduce it. Please reopen with exact steps to reproduce if you see it again.
Comment 6 Thomas Preisler 2008-03-19 18:22:17 UTC
Fixed a while ago...
Comment 7 alexandrov 2008-03-19 19:00:57 UTC
verified in build 20080318110936


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo