Bug 85737 - Redeployment --> Error
Redeployment --> Error
Status: RESOLVED FIXED
Product: serverplugins
Classification: Unclassified
Component: WebLogic
5.x
PC Linux
: P3 (vote)
: 6.x
Assigned To: Petr Hejl
issues@serverplugins
: THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-26 04:40 UTC by Marco Walther
Modified: 2007-09-17 15:08 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Screen shot (93.62 KB, image/png)
2006-09-26 04:41 UTC, Marco Walther
Details
WL91_redeploy1.png (126.50 KB, image/png)
2006-09-27 22:50 UTC, Marco Walther
Details
WL91_redeploy2.png (83.76 KB, image/png)
2006-09-27 22:50 UTC, Marco Walther
Details
WL91_redeploy3.png (95.53 KB, image/png)
2006-09-27 22:51 UTC, Marco Walther
Details
messages.log (68.86 KB, text/plain)
2006-09-27 22:52 UTC, Marco Walther
Details
patch #1 (11.58 KB, patch)
2006-09-29 12:16 UTC, Sherold Dev
Details | Diff
patch #2 (14.57 KB, patch)
2006-09-29 12:16 UTC, Sherold Dev
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Marco Walther 2006-09-26 04:40:16 UTC
When I try to redeploy an web application to Weblogic 9, I get the following 
in the Output Window and the WL node in the Runtime tab has a `wait'-child:

init:
deps-module-jar:
deps-ear-jar:
deps-jar:
library-inclusion-in-archive:
library-inclusion-in-manifest:
compile:
compile-jsps:
do-dist:
dist:
/export/home/marcow/WebApplication13/nbproject/build-impl.xml:469: Deployment 
error:
[J2EE Deployment SPI:260111]Errors detected attempting to communicate with 
admin server.
See the server log for details.
BUILD FAILED (total time: 0 seconds)
Comment 1 Marco Walther 2006-09-26 04:41:39 UTC
Created attachment 34480 [details]
Screen shot
Comment 2 Marco Walther 2006-09-26 04:47:23 UTC
Some more interesting stuff from the ide log:

<Sep 25, 2006 8:33:40 PM PDT> <Warning> <JNDI> <BEA-050001> <WLContext.close() 
w
as called in a different thread than the one in which it was created.>
INFORMATIONAL *********** Exception occurred ************ at 8:33 PM on Sep 
25,
2006
weblogic.deploy.api.spi.exceptions.ServerConnectionException: [J2EE Deployment 
S
PI:260111]Errors detected attempting to communicate with admin server.
        at 
weblogic.deploy.api.spi.deploy.mbeans.MBeanCache.getMBeans(MBeanCache
.java:63)
        at 
weblogic.deploy.api.spi.deploy.mbeans.ModuleCache.getModules(ModuleCa
che.java:85)
        at 
weblogic.deploy.api.spi.deploy.internal.ServerConnectionImpl.getModul
es(ServerConnectionImpl.java:549)
        at 
weblogic.deploy.api.spi.deploy.WebLogicDeploymentManagerImpl.getAvail
ableModules(WebLogicDeploymentManagerImpl.java:533)
        at 
org.netbeans.modules.j2ee.weblogic9.WLDeploymentManager.getAvailableM
odules(WLDeploymentManager.java:312)
        at 
org.netbeans.modules.j2ee.deployment.impl.TargetServer.getAvailableTM
IDsMap(TargetServer.java:298)
        at 
org.netbeans.modules.j2ee.deployment.impl.TargetServer.processLastTar
getModules(TargetServer.java:334)
        at 
org.netbeans.modules.j2ee.deployment.impl.TargetServer.init(TargetSer
ver.java:108)
        at 
org.netbeans.modules.j2ee.deployment.impl.TargetServer.deploy(TargetS
erver.java:445)
[catch] at 
org.netbeans.modules.j2ee.deployment.devmodules.api.Deployment.deploy
(Deployment.java:106)
        at org.netbeans.modules.j2ee.ant.Deploy.execute(Deploy.java:82)
        at 
org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:275)
        at org.apache.tools.ant.Task.perform(Task.java:364)
        at org.apache.tools.ant.Target.execute(Target.java:341)
        at org.apache.tools.ant.Target.performTasks(Target.java:369)
        at 
org.apache.tools.ant.Project.executeSortedTargets(Project.java:1216)
        at org.apache.tools.ant.Project.executeTarget(Project.java:1185)
        at 
org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExe
cutor.java:40)
        at org.apache.tools.ant.Project.executeTargets(Project.java:1068)
        at 
org.apache.tools.ant.module.bridge.impl.BridgeImpl.run(BridgeImpl.jav
a:240)
        at 
org.apache.tools.ant.module.run.TargetExecutor.run(TargetExecutor.jav
a:293)
        at 
org.netbeans.core.execution.RunClassThread.run(RunClassThread.java:13
1)
Caused by: weblogic.management.jmx.RemoteRuntimeException: 
java.io.IOException:
The client has been closed.
        at 
weblogic.management.jmx.MBeanServerInvocationHandler.checkThrowsIOExc
eption(MBeanServerInvocationHandler.java:427)
        at 
weblogic.management.jmx.MBeanServerInvocationHandler.invoke(MBeanServ
erInvocationHandler.java:228)
        at $Proxy24.getLibraries(Unknown Source)
        at 
weblogic.deploy.api.spi.deploy.mbeans.ModuleCache.getTypedMBeans(Modu
leCache.java:57)
        at 
weblogic.deploy.api.spi.deploy.mbeans.MBeanCache.getMBeans(MBeanCache
.java:54)
        ... 21 more
Caused by: java.io.IOException: The client has been closed.
        at 
com.sun.jmx.remote.internal.ClientCommunicatorAdmin.restart(ClientCom
municatorAdmin.java:74)
        at 
com.sun.jmx.remote.internal.ClientCommunicatorAdmin.gotIOException(Cl
ientCommunicatorAdmin.java:34)
        at 
javax.management.remote.rmi.RMIConnector$RMIClientCommunicatorAdmin.g
otIOException(RMIConnector.java:1410)
        at 
javax.management.remote.rmi.RMIConnector$RemoteMBeanServerConnection.
getAttribute(RMIConnector.java:858)
        at 
javax.management.MBeanServerInvocationHandler.invoke(MBeanServerInvoc
ationHandler.java:175)
        at 
weblogic.management.jmx.MBeanServerInvocationHandler.doInvoke(MBeanSe
rverInvocationHandler.java:341)
        at 
weblogic.management.jmx.MBeanServerInvocationHandler.invoke(MBeanServ
erInvocationHandler.java:224)
        ... 24 more
INFORMATIONAL *********** Exception occurred ************ at 8:34 PM on Sep 
25,
2006
weblogic.deploy.api.spi.exceptions.ServerConnectionException: [J2EE Deployment 
S
PI:260111]Errors detected attempting to communicate with admin server.
        at 
weblogic.deploy.api.spi.deploy.mbeans.MBeanCache.getMBeans(MBeanCache
.java:63)
        at 
weblogic.deploy.api.spi.deploy.mbeans.ModuleCache.getModules(ModuleCa
che.java:85)
        at 
weblogic.deploy.api.spi.deploy.internal.ServerConnectionImpl.getModul
es(ServerConnectionImpl.java:549)
        at 
weblogic.deploy.api.spi.deploy.WebLogicDeploymentManagerImpl.getAvail
ableModules(WebLogicDeploymentManagerImpl.java:533)
        at 
org.netbeans.modules.j2ee.weblogic9.WLDeploymentManager.getAvailableM
odules(WLDeploymentManager.java:312)
        at 
org.netbeans.modules.j2ee.deployment.impl.TargetServer.getAvailableTM
IDsMap(TargetServer.java:298)
        at 
org.netbeans.modules.j2ee.deployment.impl.TargetServer.processLastTar
getModules(TargetServer.java:334)
        at 
org.netbeans.modules.j2ee.deployment.impl.TargetServer.init(TargetSer
ver.java:108)
        at 
org.netbeans.modules.j2ee.deployment.impl.TargetServer.deploy(TargetS
erver.java:445)
[catch] at 
org.netbeans.modules.j2ee.deployment.devmodules.api.Deployment.deploy
(Deployment.java:106)
        at org.netbeans.modules.j2ee.ant.Deploy.execute(Deploy.java:82)
        at 
org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:275)
        at org.apache.tools.ant.Task.perform(Task.java:364)
        at org.apache.tools.ant.Target.execute(Target.java:341)
        at org.apache.tools.ant.Target.performTasks(Target.java:369)
        at 
org.apache.tools.ant.Project.executeSortedTargets(Project.java:1216)
        at org.apache.tools.ant.Project.executeTarget(Project.java:1185)
        at 
org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExe
cutor.java:40)
        at org.apache.tools.ant.Project.executeTargets(Project.java:1068)
        at 
org.apache.tools.ant.module.bridge.impl.BridgeImpl.run(BridgeImpl.jav
a:240)
        at 
org.apache.tools.ant.module.run.TargetExecutor.run(TargetExecutor.jav
a:293)
        at 
org.netbeans.core.execution.RunClassThread.run(RunClassThread.java:13
1)
Caused by: weblogic.management.jmx.RemoteRuntimeException: 
java.io.IOException:
The client has been closed.
        at 
weblogic.management.jmx.MBeanServerInvocationHandler.checkThrowsIOExc
eption(MBeanServerInvocationHandler.java:427)
        at 
weblogic.management.jmx.MBeanServerInvocationHandler.invoke(MBeanServ
erInvocationHandler.java:228)
        at $Proxy24.getAppDeployments(Unknown Source)
        at 
weblogic.deploy.api.spi.deploy.mbeans.ModuleCache.getTypedMBeans(Modu
leCache.java:55)
        at 
weblogic.deploy.api.spi.deploy.mbeans.MBeanCache.getMBeans(MBeanCache
.java:54)
        ... 21 more
Caused by: java.io.IOException: The client has been closed.
        at 
com.sun.jmx.remote.internal.ClientCommunicatorAdmin.restart(ClientCom
municatorAdmin.java:74)
        at 
com.sun.jmx.remote.internal.ClientCommunicatorAdmin.gotIOException(Cl
ientCommunicatorAdmin.java:34)
        at 
javax.management.remote.rmi.RMIConnector$RMIClientCommunicatorAdmin.g
otIOException(RMIConnector.java:1410)
        at 
javax.management.remote.rmi.RMIConnector$RemoteMBeanServerConnection.
getAttribute(RMIConnector.java:858)
        at 
javax.management.MBeanServerInvocationHandler.invoke(MBeanServerInvoc
ationHandler.java:175)
        at 
weblogic.management.jmx.MBeanServerInvocationHandler.doInvoke(MBeanSe
rverInvocationHandler.java:341)
        at 
weblogic.management.jmx.MBeanServerInvocationHandler.invoke(MBeanServ
erInvocationHandler.java:224)
        ... 24 more
INFORMATIONAL *********** Exception occurred ************ at 8:34 PM on Sep 
25,
2006
weblogic.management.jmx.RemoteRuntimeException: java.io.IOException: The 
client
has been closed.
        at 
weblogic.management.jmx.MBeanServerInvocationHandler.checkThrowsIOExc
eption(MBeanServerInvocationHandler.java:427)
        at 
weblogic.management.jmx.MBeanServerInvocationHandler.invoke(MBeanServ
erInvocationHandler.java:228)
        at $Proxy28.isInternalApp(Unknown Source)
        at 
weblogic.deploy.api.spi.deploy.mbeans.ModuleCache.getModules(ModuleCa
che.java:96)
        at 
weblogic.deploy.api.spi.deploy.internal.ServerConnectionImpl.getModul
es(ServerConnectionImpl.java:549)
        at 
weblogic.deploy.api.spi.deploy.WebLogicDeploymentManagerImpl.getAvail
ableModules(WebLogicDeploymentManagerImpl.java:533)
        at 
org.netbeans.modules.j2ee.weblogic9.WLDeploymentManager.getAvailableM
odules(WLDeploymentManager.java:312)
        at 
org.netbeans.modules.j2ee.deployment.impl.TargetServer.getAvailableTM
IDsMap(TargetServer.java:298)
        at 
org.netbeans.modules.j2ee.deployment.impl.TargetServer.processLastTar
getModules(TargetServer.java:334)
        at 
org.netbeans.modules.j2ee.deployment.impl.TargetServer.init(TargetSer
ver.java:108)
        at 
org.netbeans.modules.j2ee.deployment.impl.TargetServer.deploy(TargetS
erver.java:445)
[catch] at 
org.netbeans.modules.j2ee.deployment.devmodules.api.Deployment.deploy
(Deployment.java:106)
        at org.netbeans.modules.j2ee.ant.Deploy.execute(Deploy.java:82)
        at 
org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:275)
        at org.apache.tools.ant.Task.perform(Task.java:364)
        at org.apache.tools.ant.Target.execute(Target.java:341)
        at org.apache.tools.ant.Target.performTasks(Target.java:369)
        at 
org.apache.tools.ant.Project.executeSortedTargets(Project.java:1216)
        at org.apache.tools.ant.Project.executeTarget(Project.java:1185)
        at 
org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExe
cutor.java:40)
        at org.apache.tools.ant.Project.executeTargets(Project.java:1068)
        at 
org.apache.tools.ant.module.bridge.impl.BridgeImpl.run(BridgeImpl.jav
a:240)
        at 
org.apache.tools.ant.module.run.TargetExecutor.run(TargetExecutor.jav
a:293)
        at 
org.netbeans.core.execution.RunClassThread.run(RunClassThread.java:13
1)
Caused by: java.io.IOException: The client has been closed.
        at 
com.sun.jmx.remote.internal.ClientCommunicatorAdmin.restart(ClientCom
municatorAdmin.java:74)
        at 
com.sun.jmx.remote.internal.ClientCommunicatorAdmin.gotIOException(Cl
ientCommunicatorAdmin.java:34)
        at 
javax.management.remote.rmi.RMIConnector$RMIClientCommunicatorAdmin.g
otIOException(RMIConnector.java:1410)
        at 
javax.management.remote.rmi.RMIConnector$RemoteMBeanServerConnection.
getAttribute(RMIConnector.java:858)
        at 
javax.management.MBeanServerInvocationHandler.invoke(MBeanServerInvoc
ationHandler.java:184)
        at 
weblogic.management.jmx.MBeanServerInvocationHandler.doInvoke(MBeanSe
rverInvocationHandler.java:341)
        at 
weblogic.management.jmx.MBeanServerInvocationHandler.invoke(MBeanServ
erInvocationHandler.java:224)
        ... 22 more
INFORMATIONAL *********** Exception occurred ************ at 8:34 PM on Sep 
25,
2006
weblogic.deploy.api.spi.exceptions.ServerConnectionException: [J2EE Deployment 
S
PI:260111]Errors detected attempting to communicate with admin server.
        at 
weblogic.deploy.api.spi.deploy.mbeans.MBeanCache.getMBeans(MBeanCache
.java:63)
        at 
weblogic.deploy.api.spi.deploy.mbeans.ModuleCache.getModules(ModuleCa
che.java:85)
        at 
weblogic.deploy.api.spi.deploy.internal.ServerConnectionImpl.getModul
es(ServerConnectionImpl.java:549)
        at 
weblogic.deploy.api.spi.deploy.WebLogicDeploymentManagerImpl.getAvail
ableModules(WebLogicDeploymentManagerImpl.java:533)
        at 
org.netbeans.modules.j2ee.weblogic9.WLDeploymentManager.getAvailableM
odules(WLDeploymentManager.java:312)
        at 
org.netbeans.modules.j2ee.deployment.impl.TargetServer.getAvailableTM
IDsMap(TargetServer.java:298)
        at 
org.netbeans.modules.j2ee.deployment.impl.TargetServer.processLastTar
getModules(TargetServer.java:334)
        at 
org.netbeans.modules.j2ee.deployment.impl.TargetServer.init(TargetSer
ver.java:108)
        at 
org.netbeans.modules.j2ee.deployment.impl.TargetServer.deploy(TargetS
erver.java:445)
[catch] at 
org.netbeans.modules.j2ee.deployment.devmodules.api.Deployment.deploy
(Deployment.java:106)
        at org.netbeans.modules.j2ee.ant.Deploy.execute(Deploy.java:82)
        at 
org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:275)
        at org.apache.tools.ant.Task.perform(Task.java:364)
        at org.apache.tools.ant.Target.execute(Target.java:341)
        at org.apache.tools.ant.Target.performTasks(Target.java:369)
        at 
org.apache.tools.ant.Project.executeSortedTargets(Project.java:1216)
        at org.apache.tools.ant.Project.executeTarget(Project.java:1185)
        at 
org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExe
cutor.java:40)
        at org.apache.tools.ant.Project.executeTargets(Project.java:1068)
        at 
org.apache.tools.ant.module.bridge.impl.BridgeImpl.run(BridgeImpl.jav
a:240)
        at 
org.apache.tools.ant.module.run.TargetExecutor.run(TargetExecutor.jav
a:293)
        at 
org.netbeans.core.execution.RunClassThread.run(RunClassThread.java:13
1)
Caused by: weblogic.management.jmx.RemoteRuntimeException: 
java.io.IOException:
The client has been closed.
        at 
weblogic.management.jmx.MBeanServerInvocationHandler.checkThrowsIOExc
eption(MBeanServerInvocationHandler.java:427)
        at 
weblogic.management.jmx.MBeanServerInvocationHandler.invoke(MBeanServ
erInvocationHandler.java:228)
        at $Proxy24.getAppDeployments(Unknown Source)
        at 
weblogic.deploy.api.spi.deploy.mbeans.ModuleCache.getTypedMBeans(Modu
leCache.java:55)
        at 
weblogic.deploy.api.spi.deploy.mbeans.MBeanCache.getMBeans(MBeanCache
.java:54)
        ... 21 more
Caused by: java.io.IOException: The client has been closed.
        at 
com.sun.jmx.remote.internal.ClientCommunicatorAdmin.restart(ClientCom
municatorAdmin.java:74)
        at 
com.sun.jmx.remote.internal.ClientCommunicatorAdmin.gotIOException(Cl                                                          
ientCommunicatorAdmin.java:34)
        at 
javax.management.remote.rmi.RMIConnector$RMIClientCommunicatorAdmin.g                                                          
otIOException(RMIConnector.java:1410)
        at 
javax.management.remote.rmi.RMIConnector$RemoteMBeanServerConnection.                                                          
getAttribute(RMIConnector.java:858)
        at 
javax.management.MBeanServerInvocationHandler.invoke(MBeanServerInvoc                                                          
ationHandler.java:175)
        at 
weblogic.management.jmx.MBeanServerInvocationHandler.doInvoke(MBeanSe                                                          
rverInvocationHandler.java:341)
        at 
weblogic.management.jmx.MBeanServerInvocationHandler.invoke(MBeanServ                                                          
erInvocationHandler.java:224)
        ... 24 more
No Data Source configurations found in XML file: datasourceconfig.xml
<Sep 25, 2006 8:43:11 PM PDT> <Warning> <JNDI> <BEA-050001> <WLContext.close() 
w                                                          as called in a 
different thread than the one in which it was created.>
Comment 3 Petr Jiricka 2006-09-26 08:31:08 UTC
Stepan, will you please look at this? Thanks.
Comment 4 Sherold Dev 2006-09-26 18:50:49 UTC
I cannot reproduce the redeployment issue. Can you please provide more info:
what JDK is the IDE and the server running on, what exact version of the
WebLogic server do you use, etc.

And also what does your web app do? Could you attach it to the issue?

BTW, does the "No Data Source configurations found in XML file:
datasourceconfig.xml" message say anything to you? Could it be somehow related?


The part about the wait child node is a known issue 77287.
Comment 5 Marco Walther 2006-09-26 19:40:03 UTC
Now I saw the `same?' problem on the first deployment of a new VWP project.

-------------------------------------------------------------------
INFORMATIONAL *********** Exception occurred ************ at 11:17 AM on Sep 
26, 2006
weblogic.management.jmx.RemoteRuntimeException: java.io.IOException: The 
client has been closed.
        at 
weblogic.management.jmx.MBeanServerInvocationHandler.checkThrowsIOException(MBeanServerInvocationHandler.java:427)
        at 
weblogic.management.jmx.MBeanServerInvocationHandler.invoke(MBeanServerInvocationHandler.java:228)
        at $Proxy28.isInternalApp(Unknown Source)
        at 
weblogic.deploy.api.spi.deploy.mbeans.ModuleCache.getModules(ModuleCache.java:96)
        at 
weblogic.deploy.api.spi.deploy.internal.ServerConnectionImpl.getModules(ServerConnectionImpl.java:549)
        at 
weblogic.deploy.api.spi.deploy.WebLogicDeploymentManagerImpl.getAvailableModules(WebLogicDeploymentManagerImpl.java:533)
        at 
org.netbeans.modules.j2ee.weblogic9.WLDeploymentManager.getAvailableModules(WLDeploymentManager.java:312)
        at 
org.netbeans.modules.j2ee.deployment.impl.TargetServer.getAvailableTMIDsMap(TargetServer.java:298)
        at 
org.netbeans.modules.j2ee.deployment.impl.TargetServer.checkUndeployForSharedReferences(TargetServer.java:254)
        at 
org.netbeans.modules.j2ee.deployment.impl.TargetServer.checkUndeployForSharedReferences(TargetServer.java:203)
        at 
org.netbeans.modules.j2ee.deployment.impl.TargetServer.checkUndeployForSharedReferences(TargetServer.java:200)
        at 
org.netbeans.modules.j2ee.deployment.impl.TargetServer.processLastTargetModules(TargetServer.java:320)
        at 
org.netbeans.modules.j2ee.deployment.impl.TargetServer.init(TargetServer.java:108)
        at 
org.netbeans.modules.j2ee.deployment.impl.TargetServer.deploy(TargetServer.java:445)
[catch] at 
org.netbeans.modules.j2ee.deployment.devmodules.api.Deployment.deploy(Deployment.java:106)
        at org.netbeans.modules.j2ee.ant.Deploy.execute(Deploy.java:82)
        at 
org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:275)
        at org.apache.tools.ant.Task.perform(Task.java:364)
        at org.apache.tools.ant.Target.execute(Target.java:341)
        at org.apache.tools.ant.Target.performTasks(Target.java:369)
        at 
org.apache.tools.ant.Project.executeSortedTargets(Project.java:1216)
        at org.apache.tools.ant.Project.executeTarget(Project.java:1185)
        at 
org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:40)
        at org.apache.tools.ant.Project.executeTargets(Project.java:1068)
        at 
org.apache.tools.ant.module.bridge.impl.BridgeImpl.run(BridgeImpl.java:240)
        at 
org.apache.tools.ant.module.run.TargetExecutor.run(TargetExecutor.java:293)
        at 
org.netbeans.core.execution.RunClassThread.run(RunClassThread.java:131)
Caused by: java.io.IOException: The client has been closed.
        at 
com.sun.jmx.remote.internal.ClientCommunicatorAdmin.restart(ClientCommunicatorAdmin.java:74)
        at 
com.sun.jmx.remote.internal.ClientCommunicatorAdmin.gotIOException(ClientCommunicatorAdmin.java:34)
        at 
javax.management.remote.rmi.RMIConnector$RMIClientCommunicatorAdmin.gotIOException(RMIConnector.java:1410)
        at 
javax.management.remote.rmi.RMIConnector$RemoteMBeanServerConnection.getAttribute(RMIConnector.java:858)
        at 
javax.management.MBeanServerInvocationHandler.invoke(MBeanServerInvocationHandler.java:184)
        at 
weblogic.management.jmx.MBeanServerInvocationHandler.doInvoke(MBeanServerInvocationHandler.java:341)
        at 
weblogic.management.jmx.MBeanServerInvocationHandler.invoke(MBeanServerInvocationHandler.java:224)
        ... 25 more
<Sep 26, 2006 11:17:58 AM PDT> <Warning> <JNDI> <BEA-050001> 
<WLContext.close() was called in a different thread than the one in which it 
was created.>
-------------------------------------------------------------------------

That is with
  Product Version         = NetBeans 5.5 Dev (Build 200609181130)
  Operating System        = Linux version 2.6.15-27-686 running on i386
  Java; VM; Vendor; Home  = 1.5.0_06; Java HotSpot(TM) Server VM 1.5.0_06-b05; 
Sun Microsystems 
Inc.; /export/home/marcow/rave/build_trunk/src/ravebuild/ship-java/jre

Weblogic 9.0.

BUT I'm running on a Centrino Duo, maybe that makes a difference in the thread 
scheduling? That also seems to trigger to switch the jvm into server mode??
 
Comment 6 Sherold Dev 2006-09-27 13:18:48 UTC
I've found similar issue 67170.
Comment 7 Sherold Dev 2006-09-27 15:59:29 UTC
I am still not able to reproduce this issue.

I've tested it on both WebLogic 9.0 and WebLogic 9.1 on my Centrino notebook and
also on dual AMD workstation.

Could you please try it also on WL 9.1?

BTW, is it random or is it 100% reproducible?
Comment 8 Sherold Dev 2006-09-27 16:15:35 UTC
Do you know of anyone else (in your team) who can reproduce it?
Comment 9 Marco Walther 2006-09-27 22:49:19 UTC
I tried it today with WL 9.1 and NB 5.5 200609260000. I still see the same 
problem:-(

It looks like as soon as the Runtime Tab of NB believes WL is running, the 
deployment fails:-(

See WL91_redeploy1.png. I started WL outside and then started NB. But NB does 
notshow the little green badge.
WL91_redeploy2.png, the first [re]deployment worked except for a 
ClassCastException and the welcome page came up in the browser. NB did not try 
to start the WL server. So at some point it recognized WL as running. But now 
we have the little green badge.
WL91_redeploy3.png - the new redeployment failed. 

I'll also attach my current messages.log.

I'm not aware that anybody else has seen this problem. But not too many people 
are testing Weblogic support.
Comment 10 Marco Walther 2006-09-27 22:50:10 UTC
Created attachment 34636 [details]
WL91_redeploy1.png
Comment 11 Marco Walther 2006-09-27 22:50:43 UTC
Created attachment 34637 [details]
WL91_redeploy2.png
Comment 12 Marco Walther 2006-09-27 22:51:07 UTC
Created attachment 34638 [details]
WL91_redeploy3.png
Comment 13 Marco Walther 2006-09-27 22:52:57 UTC
Created attachment 34639 [details]
messages.log
Comment 14 Sherold Dev 2006-09-29 12:15:38 UTC
Marco, can you please check whether some of the following patches will make any
change? Currently I have no idea what might be the cause of this issue, so this
is just a shot in the dark:(
Comment 15 Sherold Dev 2006-09-29 12:16:17 UTC
Created attachment 34697 [details]
patch #1
Comment 16 Sherold Dev 2006-09-29 12:16:40 UTC
Created attachment 34698 [details]
patch #2
Comment 17 Marco Walther 2006-09-29 22:09:40 UTC
I used the weblogic1.diff patch and it's much better. I still see some log 
entries like

<Sep 29, 2006 1:56:10 PM PDT> <Warning> <JNDI> <BEA-050001> <WLContext.close() 
was called in a different thread than the one in which it was created.>
Copying 1 file to: 
export/home/marcow/rave/bea910/weblogic91/samples/domains/wl_server/autodeploy
<Sep 29, 2006 1:57:38 PM PDT> <Warning> <JNDI> <BEA-050001> <WLContext.close() 
was called in a different thread than the one in which it was created.>
Copying 1 file to: 
export/home/marcow/rave/bea910/weblogic91/samples/domains/wl_server/autodeploy
Copying 1 file to: 
export/home/marcow/rave/bea910/weblogic91/samples/domains/wl_server/autodeploy
<Sep 29, 2006 1:58:34 PM PDT> <Warning> <JNDI> <BEA-050001> <WLContext.close() 
was called in a different thread than the one in which it was created.>
Copying 1 file to: 
export/home/marcow/rave/bea910/weblogic91/samples/domains/wl_server/autodeploy
<Sep 29, 2006 1:58:59 PM PDT> <Warning> <JNDI> <BEA-050001> <WLContext.close() 
was called in a different thread than the one in which it was created.>
Copying 1 file to: 
export/home/marcow/rave/bea910/weblogic91/samples/domains/wl_server/autodeploy
Sep 29, 2006 2:00:30 PM ClientCommunicatorAdmin restart
WARNING: Failed to restart: java.rmi.NoSuchObjectException: The object 
identified by: '283' could not be found.  Either it was has not been exported 
or it has been collected by the distributed garbage collector.
Sep 29, 2006 2:00:30 PM ClientCommunicatorAdmin restart
WARNING: Failed to restart: java.rmi.NoSuchObjectException: The object 
identified by: '283' could not be found.  Either it was has not been exported 
or it has been collected by the distributed garbage collector.
Sep 29, 2006 2:00:30 PM ClientCommunicatorAdmin restart
WARNING: Failed to restart: java.rmi.NoSuchObjectException: The object 
identified by: '283' could not be found.  Either it was has not been exported 
or it has been collected by the distributed garbage collector.
Sep 29, 2006 2:00:30 PM ClientCommunicatorAdmin restart
WARNING: Failed to restart: java.rmi.NoSuchObjectException: The object 
identified by: '283' could not be found.  Either it was has not been exported 
or it has been collected by the distributed garbage collector.
Sep 29, 2006 2:00:30 PM ClientCommunicatorAdmin restart
WARNING: Failed to restart: java.rmi.NoSuchObjectException: The object 
identified by: '283' could not be found.  Either it was has not been exported 
or it has been collected by the distributed garbage collector.
Sep 29, 2006 2:00:30 PM ClientCommunicatorAdmin restart
WARNING: Failed to restart: java.rmi.NoSuchObjectException: The object 
identified by: '283' could not be found.  Either it was has not been exported 
or it has been collected by the distributed garbage collector.
Sep 29, 2006 2:00:30 PM ClientCommunicatorAdmin restart
WARNING: Failed to restart: java.rmi.NoSuchObjectException: The object 
identified by: '283' could not be found.  Either it was has not been exported 
or it has been collected by the distributed garbage collector.
Sep 29, 2006 2:00:30 PM ClientCommunicatorAdmin restart
WARNING: Failed to restart: java.rmi.NoSuchObjectException: The object 
identified by: '283' could not be found.  Either it was has not been exported 
or it has been collected by the distributed garbage collector.
Sep 29, 2006 2:00:30 PM ClientCommunicatorAdmin restart
WARNING: Failed to restart: java.rmi.NoSuchObjectException: The object 
identified by: '283' could not be found.  Either it was has not been exported 
or it has been collected by the distributed garbage collector.
Sep 29, 2006 2:00:30 PM ClientCommunicatorAdmin restart
WARNING: Failed to restart: java.rmi.NoSuchObjectException: The object 
identified by: '283' could not be found.  Either it was has not been exported 
or it has been collected by the distributed garbage collector.
Sep 29, 2006 2:00:30 PM ClientCommunicatorAdmin restart
WARNING: Failed to restart: java.rmi.NoSuchObjectException: The object 
identified by: '283' could not be found.  Either it was has not been exported 
or it has been collected by the distributed garbage collector.
Sep 29, 2006 2:00:30 PM ClientCommunicatorAdmin restart
WARNING: Failed to restart: java.rmi.NoSuchObjectException: The object 
identified by: '283' could not be found.  Either it was has not been exported 
or it has been collected by the distributed garbage collector.
Sep 29, 2006 2:00:30 PM ClientCommunicatorAdmin restart
WARNING: Failed to restart: java.rmi.NoSuchObjectException: The object 
identified by: '283' could not be found.  Either it was has not been exported 
or it has been collected by the distributed garbage collector.
Sep 29, 2006 2:00:30 PM ClientCommunicatorAdmin restart
WARNING: Failed to restart: java.rmi.NoSuchObjectException: The object 
identified by: '283' could not be found.  Either it was has not been exported 
or it has been collected by the distributed garbage collector.
Sep 29, 2006 2:00:30 PM ClientCommunicatorAdmin restart
WARNING: Failed to restart: java.rmi.NoSuchObjectException: The object 
identified by: '283' could not be found.  Either it was has not been exported 
or it has been collected by the distributed garbage collector.
Sep 29, 2006 2:00:30 PM ClientCommunicatorAdmin restart
WARNING: Failed to restart: java.rmi.NoSuchObjectException: The object 
identified by: '283' could not be found.  Either it was has not been exported 
or it has been collected by the distributed garbage collector.
Sep 29, 2006 2:00:30 PM ClientCommunicatorAdmin restart
WARNING: Failed to restart: java.rmi.NoSuchObjectException: The object 
identified by: '283' could not be found.  Either it was has not been exported 
or it has been collected by the distributed garbage collector.
Sep 29, 2006 2:00:30 PM ClientCommunicatorAdmin restart
WARNING: Failed to restart: java.rmi.NoSuchObjectException: The object 
identified by: '283' could not be found.  Either it was has not been exported 
or it has been collected by the distributed garbage collector.
Sep 29, 2006 2:00:30 PM ClientCommunicatorAdmin restart
WARNING: Failed to restart: java.rmi.NoSuchObjectException: The object 
identified by: '283' could not be found.  Either it was has not been exported 
or it has been collected by the distributed garbage collector.
Sep 29, 2006 2:00:30 PM ClientCommunicatorAdmin restart
WARNING: Failed to restart: java.rmi.NoSuchObjectException: The object 
identified by: '283' could not be found.  Either it was has not been exported 
or it has been collected by the distributed garbage collector.
<Sep 29, 2006 2:00:51 PM PDT> <Warning> <JNDI> <BEA-050001> <WLContext.close() 
was called in a different thread than the one in which it was created.>

but overall the communication seems to work. I tried all the different 
scenarios where I had problems before and could not reproduce my problem. I 
know, it's somewhat time sensitive but after about ten [re]deployments I feel 
good;-)
Comment 18 Petr Jiricka 2006-10-05 20:53:27 UTC
Waiver approved.
Comment 19 Dan Kolar 2007-08-02 16:04:32 UTC
Can't reproduce it on Enterprise Linux R4 U4 x86 64b, build 200708020000 jdk1.5.0_13 and Weblogic 10 (Weblogic 9 can't
be installed somehow)
Comment 20 Petr Blaha 2007-08-02 17:59:29 UTC
Downgrading priority since the bug is reproducible only on specific HW.
Comment 21 Petr Hejl 2007-09-17 15:08:46 UTC
Seems to be caused by not thread safe WL DeploymentManager.

Checking in build.xml;
/cvs/serverplugins/weblogic9/build.xml,v  <--  build.xml
new revision: 1.10; previous revision: 1.9
done
Checking in src/org/netbeans/modules/j2ee/weblogic9/Bundle.properties;
/cvs/serverplugins/weblogic9/src/org/netbeans/modules/j2ee/weblogic9/Bundle.properties,v  <--  Bundle.properties
new revision: 1.13; previous revision: 1.12
done
Checking in src/org/netbeans/modules/j2ee/weblogic9/WLDeployer.java;
/cvs/serverplugins/weblogic9/src/org/netbeans/modules/j2ee/weblogic9/WLDeployer.java,v  <--  WLDeployer.java
new revision: 1.12; previous revision: 1.11
done
Checking in src/org/netbeans/modules/j2ee/weblogic9/WLDeploymentFactory.java;
/cvs/serverplugins/weblogic9/src/org/netbeans/modules/j2ee/weblogic9/WLDeploymentFactory.java,v  <-- 
WLDeploymentFactory.java
new revision: 1.16; previous revision: 1.15
done
Checking in src/org/netbeans/modules/j2ee/weblogic9/WLDeploymentManager.java;
/cvs/serverplugins/weblogic9/src/org/netbeans/modules/j2ee/weblogic9/WLDeploymentManager.java,v  <-- 
WLDeploymentManager.java
new revision: 1.23; previous revision: 1.22
done
Checking in src/org/netbeans/modules/j2ee/weblogic9/config/EarDeploymentConfiguration.java;
/cvs/serverplugins/weblogic9/src/org/netbeans/modules/j2ee/weblogic9/config/EarDeploymentConfiguration.java,v  <-- 
EarDeploymentConfiguration.java
new revision: 1.6; previous revision: 1.5
done
Checking in src/org/netbeans/modules/j2ee/weblogic9/config/EjbDeploymentConfiguration.java;
/cvs/serverplugins/weblogic9/src/org/netbeans/modules/j2ee/weblogic9/config/EjbDeploymentConfiguration.java,v  <-- 
EjbDeploymentConfiguration.java
new revision: 1.6; previous revision: 1.5
done
Checking in src/org/netbeans/modules/j2ee/weblogic9/config/WarDeploymentConfiguration.java;
/cvs/serverplugins/weblogic9/src/org/netbeans/modules/j2ee/weblogic9/config/WarDeploymentConfiguration.java,v  <-- 
WarDeploymentConfiguration.java
new revision: 1.8; previous revision: 1.7
done
Checking in src/org/netbeans/modules/j2ee/weblogic9/optional/WLStartServer.java;
/cvs/serverplugins/weblogic9/src/org/netbeans/modules/j2ee/weblogic9/optional/WLStartServer.java,v  <--  WLStartServer.java
new revision: 1.25; previous revision: 1.24
done
RCS file: /cvs/serverplugins/weblogic9/src/org/netbeans/modules/j2ee/weblogic9/resources/weblogic-deployment-plan.xsd,v
done
Checking in src/org/netbeans/modules/j2ee/weblogic9/resources/weblogic-deployment-plan.xsd;
/cvs/serverplugins/weblogic9/src/org/netbeans/modules/j2ee/weblogic9/resources/weblogic-deployment-plan.xsd,v  <-- 
weblogic-deployment-plan.xsd
initial revision: 1.1
done
Removing src/org/netbeans/modules/j2ee/weblogic9/util/WLDebug.java;
/cvs/serverplugins/weblogic9/src/org/netbeans/modules/j2ee/weblogic9/util/WLDebug.java,v  <--  WLDebug.java
new revision: delete; previous revision: 1.4
done


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo