Bug 84702 - GF installed in a dir with white spaces doesn't start on Mac
GF installed in a dir with white spaces doesn't start on Mac
Status: VERIFIED FIXED
Product: serverplugins
Classification: Unclassified
Component: Sun Appserver 9
5.x
All Mac OS X
: P2 (vote)
: 6.x
Assigned To: Vince Kraemer
issues@serverplugins
: SPACE_IN_PATH
: 77116 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-12 14:17 UTC by Tomasz Slota
Modified: 2006-10-23 16:41 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
the patch file (16.80 KB, text/plain)
2006-09-16 01:08 UTC, Vince Kraemer
Details
Extended the error message dialog text (2.70 KB, text/plain)
2006-09-18 18:09 UTC, Vince Kraemer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tomasz Slota 2006-09-12 14:17:39 UTC
No exceptions are thrown, request to start app server times out. I have tried GF build 48 and build V1 UR1 
Build 10.
Comment 1 Vince Kraemer 2006-09-12 16:02:38 UTC
filed a while ago as https://glassfish.dev.java.net/issues/show_bug.cgi?id=694

I will figure out a way to get some kind of useful message to the user for this
case, if janey won't get this fix into GF v1 u1...
Comment 2 Vince Kraemer 2006-09-12 19:31:55 UTC
Cannot even install GF with a space in the path on linux...

https://glassfish.dev.java.net/issues/show_bug.cgi?id=603
Comment 3 Vince Kraemer 2006-09-14 01:46:14 UTC
The "fix" from the plugin is two fold:

1. change the start operation to fail faster.
2. put the error message that users get from 'asadmin start-domain' into the log
viewer that opens when users start the server.

This change also covers other cases (like failures to start the server because
another process is using one of the ports) with better error messages, faster.

There may be situations where we still need to timeout, but they will be  a lot
rarer.

Note: changes in LogViewerSupport.run() resolve a CPU usage issue if the
server's log file is not present. [the thread should have slept, but didn't]
Comment 4 Petr Jiricka 2006-09-15 16:19:01 UTC
In Glassfish issue 603 the evaluator says that spaces in paths are only
supported on Windows. So shouldn't the fix be rather to disallow installing GF
to a directory with spaces on Linux and Mac? 
Comment 5 Vince Kraemer 2006-09-16 01:08:44 UTC
Created attachment 34048 [details]
the patch file
Comment 6 Vince Kraemer 2006-09-16 01:12:21 UTC
fix in release55_dev
Comment 7 _ ludo 2006-09-16 01:42:45 UTC
Can't fix the existing installer for 8.x or 9.0
So I agree with this plugin fix.
Ludo
Comment 9 Jan Horvath 2006-09-18 17:46:26 UTC
in case of timeout the fix is OK. I get error message immediately. 
But the message doesn't contain nany warning about spaces in the installation path, only usual port 
conflict, ...
Comment 10 Vince Kraemer 2006-09-18 18:09:21 UTC
Created attachment 34104 [details]
Extended the error message dialog text
Comment 11 Jan Horvath 2006-09-19 10:37:55 UTC
ok now, you can merge this fix to release55
Comment 13 Vince Kraemer 2006-09-27 16:52:23 UTC
*** Issue 77116 has been marked as a duplicate of this issue. ***
Comment 14 Jan Horvath 2006-09-29 12:58:45 UTC
verified in build 200609290000


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo