Bug 83590 - NPE on deleting a schema to which a design pattern is being applied
NPE on deleting a schema to which a design pattern is being applied
Status: VERIFIED FIXED
Product: xml
Classification: Unclassified
Component: Schema Tools
5.x
PC Windows XP
: P1 (vote)
: TBD
Assigned To: Nam Nguyen
issues@xml
:
: 84311 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-28 13:24 UTC by Andrei Chistiakov
Modified: 2006-09-07 01:49 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrei Chistiakov 2006-08-28 13:24:43 UTC
Reproduced in build 060827 (JDK 1.6 beta 2).

To reproduce the bug:

- open flattened OTA schema;
- apply Russian Doll design pattern to the schema;
- while the pattern is being applied, delete the schema from the project.

java.lang.NullPointerException
	at
org.netbeans.modules.xml.xam.dom.AbstractDocumentModel.needsSync(AbstractDocumentModel.java:93)
	at org.netbeans.modules.xml.xam.AbstractModel.sync(AbstractModel.java:219)
	at
org.netbeans.modules.xml.axi.impl.AXIModelImpl.syncStarted(AXIModelImpl.java:145)
	at org.netbeans.modules.xml.xam.AbstractModel.sync(AbstractModel.java:220)
	at
org.netbeans.modules.xml.axi.impl.DefaultSchemaGenerator$TransformHelper.execute(DefaultSchemaGenerator.java:676)
	at
org.netbeans.modules.xml.axi.impl.DefaultSchemaGenerator.transformSchema(DefaultSchemaGenerator.java:113)
	at
org.netbeans.modules.xml.axi.impl.SchemaGeneratorFactoryImpl.transformSchema(SchemaGeneratorFactoryImpl.java:111)
	at
org.netbeans.modules.xml.schema.abe.wizard.SchemaTransformWizard$1.run(SchemaTransformWizard.java:115)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:499)
[catch] at
org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:932)
Comment 1 Nam Nguyen 2006-08-31 18:04:39 UTC
Fixed by checking for null return from model source lookup.

/cvs/xml/xam/src/org/netbeans/modules/xml/xam/dom/Attic/AbstractDocumentModel.java,v
 <--  AbstractDocumentModel.java
new revision: 1.1.2.23; previous revision: 1.1.2.22
Comment 2 Andrei Chistiakov 2006-09-01 13:35:10 UTC
Verified in build 060831_2.
Comment 3 Nam Nguyen 2006-09-07 01:49:52 UTC
*** Issue 84311 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo