Bug 83384 - Deadlock after using JavaHelp Help set wizard
Deadlock after using JavaHelp Help set wizard
Status: RESOLVED FIXED
Product: editor
Classification: Unclassified
Component: -- Other --
5.x
PC Windows XP
: P2 (vote)
: 5.x
Assigned To: issues@editor
issues@editor
: THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-24 13:55 UTC by Tomas Danek
Modified: 2007-11-05 13:44 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
thread dump (11.47 KB, text/plain)
2006-08-24 13:55 UTC, Tomas Danek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Danek 2006-08-24 13:55:13 UTC
Netbeans 5.5 200608240000
jdk 1.5.0_07
+enterprise pack
+creator pack
+mobility
+profiler
+c/c++ pack

What i did: Tried to add JavaHelp to module using JavaHelp Help Set wizard
Could not reproduce again -> P2 -> no exact steps to reproduce.

thread dump attached. Seems to me like editor's involved, if not, reassigne.
Comment 1 Tomas Danek 2006-08-24 13:55:50 UTC
Created attachment 33245 [details]
thread dump
Comment 2 Tomas Danek 2006-08-24 13:56:45 UTC
it happend during integration testing -> INTEGRATION kw. But probably unrelated.
Comment 3 Miloslav Metelka 2006-08-30 09:46:33 UTC
Fixed in trunk:

Checking in EditorModule.java;
/cvs/editor/src/org/netbeans/modules/editor/EditorModule.java,v  <-- 
EditorModule.java
new revision: 1.122; previous revision: 1.121

I will request integration into 5.5 as well.
Comment 4 Miloslav Metelka 2006-09-06 10:39:53 UTC
It's deadlock of Settings.class <-> EditorModule.HackMap resolved by only
syncing on Settings.class.
Comment 6 Miloslav Metelka 2006-09-08 15:56:53 UTC
Integrated into release55:
Checking in src/org/netbeans/modules/editor/EditorModule.java;
/cvs/editor/src/org/netbeans/modules/editor/EditorModule.java,v  <-- 
EditorModule.java
new revision: 1.119.26.2; previous revision: 1.119.26.1


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo