Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 83247 - Use arrow for reordering tabs
Use arrow for reordering tabs
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Window System
6.x
PC All
: P2 with 1 vote (vote)
: 7.4
Assigned To: issues@platform
issues@platform
:
: 68536 104838 166447 189484 (view as bug list)
Depends on:
Blocks: 70468
  Show dependency treegraph
 
Reported: 2006-08-23 05:32 UTC by _ gtzabari
Modified: 2013-04-16 20:20 UTC (History)
5 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description _ gtzabari 2006-08-23 05:32:53 UTC
Please consider adopting the same UI as FireFox whereby a small arrow denotes
the insertion position when changing the order of tabs.

The current UI (red border outline) is great for when one wishes to dock a
document to the side of the screen because it emphasizes the bounds of the new
container but it is a poor match for simply repositioning tabs.

The small arrow is a good match because it emphasizes an exact position
(insertation point) as opposed to an entire border which isn't relevant when
reordering tabs.

Also, I find that the current UI is difficult to use across remote-desktop where
drawing the border is rather slow as opposed to drawing the smaller arrow.
Comment 1 Marian Mirilovic 2006-11-26 21:09:38 UTC
I agree with reporter, it would be better (and hopefully faster) 
Comment 2 Lukas Hasik 2008-03-10 12:19:17 UTC
the firefox "situation" is much more easier. You cannot redesign WS in firefox. 
In NB you can either move tab into new position in tab group or you can move the whole window to new position.

OTOH, indication of drop position between tabs would be useful.
Comment 3 _ gtzabari 2008-03-10 14:09:47 UTC
The primary problem I am trying to solve is how awkward it is to drag-n-drop. I find the existing mechanism is too "shaky".

I would suggest experimenting with the following approach:

1) Get rid of the preview thumbnail. It blocks my view so I can't see where I'm dropping the item.
2) Use arrows to indicate tab-drop positions
3) When a "large drag" operation begins (i.e. move a tab into its own pane), outline all possible drop positions
(everything except arrows) in some neutral (gray?) color as if they are unfocused. When the user drags the mouse over a
possible target, shift its color to some primary color (red?) to indicate it gains focus. If the user drops the item, it
gets dropped into that target.
4) Large drop position discussed in #3 should not intersect the arrow drop positions. That is, if I drag the mouse over
the horizontal span of tabs, the arrows should display. The red drop target should only display *below* this span so
there is no ambiguity that dropping inside the span orders tabs whereas dropping outside it changes panes. Right now you
will notice that dragging a tab into a new "top pane" will highlight an area that includes the tab-span.
Comment 4 _ gtzabari 2009-10-12 16:28:33 UTC
This is the only remaining item blocking issue #70468. Can you please re-evaluate this issue?
Comment 5 David Simonek 2009-10-13 08:20:27 UTC
AFAIK it's not on our plan, not enough resources, sorry. Patches from community are welcome, as always.
Comment 6 markiewb 2013-03-10 22:25:03 UTC
*** Bug 189484 has been marked as a duplicate of this bug. ***
Comment 7 markiewb 2013-03-10 22:26:02 UTC
*** Bug 104838 has been marked as a duplicate of this bug. ***
Comment 8 markiewb 2013-03-10 22:28:04 UTC
*** Bug 68536 has been marked as a duplicate of this bug. ***
Comment 9 markiewb 2013-03-10 23:00:52 UTC
*** Bug 166447 has been marked as a duplicate of this bug. ***
Comment 10 Stanislav Aubrecht 2013-04-04 11:13:40 UTC
core-main 6676cd44c53f

The default shortcuts are Ctrl+Shift+Alt+Left and Ctrl+Shift+Alt+Right
Comment 11 _ gtzabari 2013-04-10 14:54:39 UTC
Please reopen this issue. I have two outstanding complaints:

1. The bulk of my complaint was about reordering tabs by mouse, which is not fixed.
2. The keyboard binding is too long and frankly I don't think we need a keyboard binding for this operation.
Comment 12 Stanislav Aubrecht 2013-04-12 06:24:05 UTC
(In reply to comment #11)
> Please reopen this issue. I have two outstanding complaints:
> 
> 1. The bulk of my complaint was about reordering tabs by mouse, which is not
> fixed.
> 2. The keyboard binding is too long and frankly I don't think we need a
> keyboard binding for this operation.

Please file new issues, thanks.
Comment 13 _ gtzabari 2013-04-16 20:20:23 UTC
Filed issue 228632. Thanks.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo