Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 82612 - BLueprint 4 tests fail
BLueprint 4 tests fail
Status: VERIFIED FIXED
Product: usersguide
Classification: Unclassified
Component: SOA
5.x
All All
: P1 (vote)
: 5.x
Assigned To: Ryan Kennedy
issues@soa
55EP_RR_DOCS
:
Depends on: 85420
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-14 13:52 UTC by Mikhail Kondratyev
Modified: 2006-10-23 08:44 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mikhail Kondratyev 2006-08-14 13:52:42 UTC
Tested with build 17a RC1
Steps to reproduce:
 - create a new Blueprint4 project
 - deploy it
 - select project and click Test in context menu
The tests will fail
Comment 1 _ hong_lin 2006-08-14 18:30:54 UTC
Blueprint 4 tests have to be run in an order:

poServiceRequest -> poRequestCancel
or
poServiceRequest -> poRequestConfirm

This is not a show stopper. But to avoid this fail test result, developer may
need to re-order these tests. Or add a note in the BluePrint4 document.
Comment 2 Michael Frisino 2006-08-22 16:20:28 UTC
Ryan,

What is story here? Is this by design, that one blueprint depends on prior
blueprints? Is there precedent for this in other blueprints in NB? Or is user
assumption that they can run any blueprint in any order?
Comment 3 Ryan Kennedy 2006-08-22 20:18:29 UTC
Users should be able to run the BPEL BluePrints independent of each another. 

For BluePrint 4, however, the tests need to be run in a specific sequence due to
the use of correlation.

poServiceRequest -> poRequestConfirm 
or
poServiceRequest -> poRequestCancel

PCM has confirmed that this note will be added to the FAQ list by docs team. 

For FCS, we may want to modify the naming so as to suggest the sequence in which
the tests need to be run.

e.g.
test1_poServiceRequest 
test2_poRequestConfirm 
test3_poRequestCancel
Comment 4 Michael Frisino 2006-08-22 21:35:01 UTC
sorry, my mistake. I thought the "order" issue was blueprint order. I see now it
is test run order. It is perfectly understandable. This  does raise the
possibility of a separate RFE for a "test scenario" comprised of an ordered set
of test cases, specifically for situations like this, where correlation is required.
Comment 5 kiran_bhumana 2006-09-20 00:25:00 UTC
The documentation reflects that the tests should be run in order. When the test
driver framwork is ready to accomodate as Mike Frisino has already pointed out,
we would do such a thing. Renaming the tests is not going to solve this issue.
The names of the tests curently are most appropriate and i believe are well left
alone.
Comment 6 Ryan Kennedy 2006-09-20 07:57:58 UTC
Note has also been added to the NB Ent Pack FAQ list suggesting order in which
BP4 tests should be run. Closing bug.
http://www.netbeans.org/kb/faqs/#Enterprise_Pack
Comment 7 Mikhail Kondratyev 2006-09-21 13:13:02 UTC
Can't verify because of bug 85420
Comment 8 Alexander Pepin 2006-09-22 13:05:24 UTC
tests succeed if they are run in documented order
verified in build 060921 
Comment 9 Michael Frisino 2006-10-13 11:45:34 UTC
If this is still an issue it should be documented in release notes. 

Ryan, does this restriction still apply. Is test run order still significant?
Comment 10 Ryan Kennedy 2006-10-16 17:01:22 UTC
Yes, Blueprint 4 tests still need to be run in a specific order. The release
notes wiki has been updated to reflect this new entry, which will be added to
the release notes by Alyona Stashkova (release notes owner).
Comment 11 astashkova 2006-10-23 08:44:58 UTC
Added to RNs

Use the following link to review the wording and location of the issue in the
staged Release Notes
http://nbstaging.czech/community/releases/55/entpack_relnotes.html#82612


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo