Bug 82142 - NPE at sun.awt.X11.XSelection.checkChange when DnD
NPE at sun.awt.X11.XSelection.checkChange when DnD
Status: RESOLVED WONTFIX
Product: platform
Classification: Unclassified
Component: Window System
6.x
Sun Solaris
: P3 (vote)
: 6.x
Assigned To: David Simonek
issues@platform
jdk_bug_6511815
:
: 77516 92106 95457 96574 97356 97558 98086 100272 102683 103395 104428 104649 106259 111319 112344 114675 118507 144205 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-08 10:07 UTC by Max Sauer
Modified: 2008-12-22 13:41 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (478 bytes, text/plain)
2008-05-22 04:07 UTC, andersongmarques
Details
stacktrace (478 bytes, text/plain)
2008-06-13 11:07 UTC, kate
Details
stacktrace (478 bytes, text/plain)
2008-06-14 21:05 UTC, andersongmarques
Details
stacktrace (478 bytes, text/plain)
2008-07-12 10:15 UTC, aaljabari
Details
stacktrace (478 bytes, text/plain)
2008-07-12 10:23 UTC, aaljabari
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Max Sauer 2006-08-08 10:07:16 UTC
Following NPE appeared when user tries to add an action to existing toolbar via
dragging desired item from "Customise toolbars" dialog:

java.lang.NullPointerException
	at sun.awt.X11.XSelection.checkChange(XSelection.java:749)
	at sun.awt.X11.XSelection.access$200(XSelection.java:30)
	at sun.awt.X11.XSelection$SelectionEventHandler.dispatchEvent(XSelection.java:758)
	at sun.awt.X11.XToolkit.dispatchEvent(XToolkit.java:482)
	at sun.awt.X11.XToolkit.run(XToolkit.java:626)
	at sun.awt.X11.XToolkit.run(XToolkit.java:560)
[catch] at java.lang.Thread.run(Thread.java:619)

Steps to reproduce:
-------------------
1) Start IDE
2) Right-click a toolbar|Customise...
3) Drag "New Watch..." next to memory meter toolbar
=> NPE

------
NetBeans IDE Dev (Build 200608071800)
1.6.0-rc; Java HotSpot(TM) 64-Bit Server VM 1.6.0-rc-b94
SunOS version 5.10 running on sparcv9
en (nb); ISO646-US
Comment 1 Marian Mirilovic 2006-08-08 12:10:07 UTC
I've been seeing this for long time , it's JDK bug :
http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6182905
Comment 2 Max Sauer 2006-08-08 12:28:30 UTC
Yes, seems to affect almost all drag&drop actions. Marking as verified.
Comment 3 Jiri Prox 2007-04-04 10:55:58 UTC
*** Issue 96574 has been marked as a duplicate of this issue. ***
Comment 4 Marian Mirilovic 2007-04-28 20:31:24 UTC
JDK bug has been closed as duplicate of :
http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6511815
Comment 5 Marian Mirilovic 2007-04-28 20:31:50 UTC
*** Issue 92106 has been marked as a duplicate of this issue. ***
Comment 6 Marian Mirilovic 2007-04-28 20:32:48 UTC
*** Issue 102683 has been marked as a duplicate of this issue. ***
Comment 7 Marian Mirilovic 2007-04-28 20:35:37 UTC
*** Issue 97356 has been marked as a duplicate of this issue. ***
Comment 8 Marian Mirilovic 2007-04-28 20:39:38 UTC
*** Issue 97558 has been marked as a duplicate of this issue. ***
Comment 9 Marian Mirilovic 2007-04-28 20:41:00 UTC
*** Issue 98086 has been marked as a duplicate of this issue. ***
Comment 10 Marian Mirilovic 2007-04-28 20:42:06 UTC
*** Issue 77516 has been marked as a duplicate of this issue. ***
Comment 11 Marian Mirilovic 2007-04-28 20:43:26 UTC
*** Issue 95457 has been marked as a duplicate of this issue. ***
Comment 12 Marian Mirilovic 2007-04-28 20:46:16 UTC
*** Issue 100272 has been marked as a duplicate of this issue. ***
Comment 13 Marian Mirilovic 2007-05-09 10:34:37 UTC
*** Issue 103395 has been marked as a duplicate of this issue. ***
Comment 14 Lukas Jungmann 2007-05-23 16:43:39 UTC
*** Issue 104649 has been marked as a duplicate of this issue. ***
Comment 15 Jiri Prox 2007-06-11 10:39:04 UTC
*** Issue 106259 has been marked as a duplicate of this issue. ***
Comment 16 Peter Zavadsky 2007-06-15 23:41:11 UTC
*** Issue 104428 has been marked as a duplicate of this issue. ***
Comment 17 Jiri Prox 2007-07-30 12:24:03 UTC
*** Issue 111319 has been marked as a duplicate of this issue. ***
Comment 18 Vitezslav Stejskal 2007-10-11 10:20:48 UTC
*** Issue 118507 has been marked as a duplicate of this issue. ***
Comment 19 Jiri Prox 2007-10-11 10:21:38 UTC
*** Issue 118507 has been marked as a duplicate of this issue. ***
Comment 20 Max Sauer 2007-10-11 10:38:43 UTC
*** Issue 112344 has been marked as a duplicate of this issue. ***
Comment 21 ehucka 2007-11-14 08:44:58 UTC
*** Issue 114675 has been marked as a duplicate of this issue. ***
Comment 22 pratham_vishnu 2007-12-20 07:41:16 UTC
I have installed netbeans 6.0 on solaris 10 x86 with jdk1.6.0 and this error still persists.
Comment 23 Max Sauer 2007-12-20 09:30:19 UTC
Note this should be fixed in JDKs 7(b09), 6u2(b02). Please update your JDK to the latest version of JDK6, it should
help. If the problem persists, the JDK bug should be reopened, not this issue. Thanks.
Comment 24 andersongmarques 2008-05-22 04:07:38 UTC
Created attachment 61728 [details]
stacktrace
Comment 25 kate 2008-06-13 11:07:54 UTC
Created attachment 62799 [details]
stacktrace
Comment 26 andersongmarques 2008-06-14 21:05:48 UTC
Created attachment 62846 [details]
stacktrace
Comment 27 aaljabari 2008-07-12 10:15:41 UTC
Build: NetBeans IDE Dev (Build 200807040101)
VM: Java HotSpot(TM) Client VM, 1.6.0-b105, Java(TM) SE Runtime Environment, 1.6.0-b105
OS: Linux, 2.6.24-19-generic, i386

User Comments: 
Comment 28 aaljabari 2008-07-12 10:15:51 UTC
Created attachment 64375 [details]
stacktrace
Comment 29 aaljabari 2008-07-12 10:22:19 UTC
Build: NetBeans IDE Dev (Build 200807040101)
VM: Java HotSpot(TM) Client VM, 1.6.0-b105, Java(TM) SE Runtime Environment, 1.6.0-b105
OS: Linux, 2.6.24-19-generic, i386

User Comments: 
Comment 30 aaljabari 2008-07-12 10:23:01 UTC
Created attachment 64376 [details]
stacktrace
Comment 31 Jiri Prox 2008-08-19 10:46:56 UTC
*** Issue 144205 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo