Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 81528 - WSDL generation and validation bug
WSDL generation and validation bug
Status: VERIFIED FIXED
Product: xml
Classification: Unclassified
Component: WSDL Tools
5.x
All All
: P2 (vote)
: TBD
Assigned To: Shivanand Kini
issues@xml
ENTPACK_55_BETA_RN 55EP_BETA_WAIVED
:
: 81747 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-31 19:56 UTC by kiran_bhumana
Modified: 2006-08-30 22:09 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
incorrect child.wsdl (3.44 KB, application/octet-stream)
2006-07-31 19:57 UTC, kiran_bhumana
Details
second time generated correct child.wsdl (3.43 KB, application/octet-stream)
2006-07-31 19:58 UTC, kiran_bhumana
Details
original child wsdl (3.32 KB, application/octet-stream)
2006-07-31 19:59 UTC, kiran_bhumana
Details
parent wsdl that is used to import (5.12 KB, application/octet-stream)
2006-07-31 20:00 UTC, kiran_bhumana
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kiran_bhumana 2006-07-31 19:56:42 UTC
Refer the attached WSDLs. Load the child_orig.wsdl and the parent.wsdl.
Validation is fine. Import the parent.wsdl into the child_orig.wsdl, you will 
get the child.wsdl . It doesn't validate, It shows the following errors,

C:\Documents and Settings\kbhumana\BpelModule1\src\f4\corrInvRec_child.wsdl:1: 
column:1 ERROR: cvc-complex-type.2.4.a: Invalid content was found starting 
with element 'types'. One of '{WC
[##other:"http://schemas.xmlsoap.org/wsdl/"]}' is expected.
C:\Documents and Settings\kbhumana\BpelModule1\src\f4
\corrInvRec_parent.bpel:59: column:16 ERROR: Not found propertyAlias for 
property "{CorrInvRecParent}property" usage for the associated variables type 
are in any WSDL definitions directly imported by the WS-BPEL process.
C:\Documents and Settings\kbhumana\BpelModule1\src\f4\corrInvRec_child.wsdl:1: 
column:1 ERROR: cvc-complex-type.2.4.a: Invalid content was found starting 
with element 'types'. One of '{WC
[##other:"http://schemas.xmlsoap.org/wsdl/"]}' is expected.
C:\Documents and Settings\kbhumana\BpelModule1\nbproject\build-impl.xml:160: 
Found compilation errors.
BUILD FAILED (total time: 2 seconds)

Go to text mode, remove the import and the namespace that was just added. Go 
to the tree mode, and add the same import again. The generated file looks like 
child2.wsdl and there are no errors. I have been consistently been able to 
reproduce this.
Comment 1 kiran_bhumana 2006-07-31 19:57:58 UTC
Created attachment 32373 [details]
incorrect child.wsdl
Comment 2 kiran_bhumana 2006-07-31 19:58:39 UTC
Created attachment 32374 [details]
second time generated correct child.wsdl
Comment 3 kiran_bhumana 2006-07-31 19:59:32 UTC
Created attachment 32375 [details]
original child wsdl
Comment 4 kiran_bhumana 2006-07-31 20:00:13 UTC
Created attachment 32376 [details]
parent wsdl that is used to import
Comment 5 Shivanand Kini 2006-08-03 00:36:42 UTC
The given wsdl is not valid. the wsdl schema doesnot allow any extensibility
elements to be on the top. 
The current wsdl.xsd(wsdl schema) used for validation allows adding
extensibility element at the top, but not in mixed way.
The extensibility elements should occur only at the top or at the bottom or both
but not mixed.

In case of invalid wsdl, the import statement is above the partnerlinktype
definition. Hence the syntax validator gives that errormessage.
In the second case, the model adds the import after the partnerlinktype, hence
it passes(as per the current wsdl schema)

The xsd needs to be changed to allow extensibility element in the bottom. Since
this has to go into the wsdlmodel vaidator source which has already been frozen.
i will change the xsd in netbeans55 but not for the beta.

For the beta, there exists a workaround of deleting from source and adding it
again as described in the bug description.
Comment 6 Shivanand Kini 2006-08-03 18:40:21 UTC
*** Issue 81747 has been marked as a duplicate of this issue. ***
Comment 7 Shivanand Kini 2006-08-25 23:03:53 UTC
On further checking with the WS-I basic profile 1.1, my above comments are not
valid anymore. As per WS-I basic profile 1.1, elements need not be in sequence.
So both cases are valid.

I have checked in the new wsdl.xsd for validation. So with this change both
wsdl's become valid.
Comment 8 jlautz 2006-08-30 22:09:47 UTC
Verified on Windows XP NB Build 5.5 200608290000.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo