Bug 81469 - Cannot run query - AbstractMethodError
Cannot run query - AbstractMethodError
Status: VERIFIED FIXED
Product: contrib
Classification: Unclassified
Component: Jackpot
5.x
All All
: P1 (vote)
: TBD
Assigned To: issues@contrib
issues@contrib
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-31 13:18 UTC by Jiri Prox
Modified: 2006-09-14 15:08 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Prox 2006-07-31 13:18:32 UTC
NetBeans IDE Dev (Build 200607301800)
1.6.0-beta2; Java HotSpot(TM) Client VM 1.6.0-beta2-b82
Linux version 2.6.5-1.358 running on i386
en_US (nb); UTF-8
        org.netbeans.libs.javacapi [0.4.2 2 060718]
        org.netbeans.libs.javacimpl [0.4.2 2 060718]
        org.netbeans.jackpot [1.6.2 2 060718]
        org.netbeans.modules.jackpot/1 [1.5.6 6 060726]
        org.netbeans.modules.jackpot.rules [1.2.4.1 1 060718]

Exception thrown when trying to run any query.


java.lang.AbstractMethodError:
org.netbeans.modules.jackpot.ModuleContext.getJavaFileManager()Ljavax/tools/JavaFileManager;
	at org.netbeans.jackpot.builder.Engine.initialize(Engine.java:102)
	at org.netbeans.modules.jackpot.JackpotModule.createEngine(JackpotModule.java:104)
	at org.netbeans.modules.jackpot.JackpotModule.createEngine(JackpotModule.java:90)
	at
org.netbeans.modules.jackpot.ui.QueryAndRefactorAction$CommandRunner.run(QueryAndRefactorAction.java:134)
[catch] at java.lang.Thread.run(Thread.java:619)
Comment 1 _ tball 2006-08-30 18:15:54 UTC
This is caused by changes in the public javac API between Mustang builds.  A new
version of Jackpot which runs with the current Mustang build 97 will be pushed
today to the autoupdate centers.  The build 97 javac API should be very close to
the final Java 6 release API, and so is less likely to break Jackpot.
Comment 2 Jiri Prox 2006-09-04 16:07:05 UTC
verified
Comment 3 _ tball 2006-09-14 15:08:49 UTC
Issue 81651 is unrelated to this issue.  I think someone mis-typed the issue
number they wanted.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo