Bug 81230 - Deadlock when opening EAR
Deadlock when opening EAR
Status: RESOLVED DUPLICATE of bug 68106
Product: platform
Classification: Unclassified
Component: -- Other --
5.x
All All
: P2 (vote)
: 6.x
Assigned To: Petr Nejedly
issues@platform
: THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-27 09:39 UTC by Jan Horvath
Modified: 2008-12-22 19:45 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
thread dump (13.49 KB, text/plain)
2006-07-27 09:40 UTC, Jan Horvath
Details
testing project (23.96 KB, application/x-gzip)
2006-07-27 09:42 UTC, Jan Horvath
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Horvath 2006-07-27 09:39:51 UTC
build 200607270000

-start IDE
-open EAR
--> deadlock, Opening Projects progress dialog is showing 0%
Comment 1 Jan Horvath 2006-07-27 09:40:21 UTC
Created attachment 32253 [details]
thread dump
Comment 2 Jan Horvath 2006-07-27 09:42:03 UTC
Created attachment 32254 [details]
testing project
Comment 3 Martin Krauskopf 2006-07-27 15:50:29 UTC
Either the threaddump is not complete or bug in Mutex? Petre please take a look
at it. Just read accesses, no write access. More over, one is able to enter read
access and after that hangs on acquiring read access in the same stack on the
same mutex.

PS: nothing has to do with earproject, rather webproject if any
Comment 4 Petr Nejedly 2006-07-27 16:06:29 UTC
The thread dump is strange, at least (OK, MAC uses different format it seems).
I see only read accesses in there, but there might be a posted write access (not
visible in the thread dump yet) that prevents additional readers to enter.
See issue 68106, fixed in trunk.

*** This issue has been marked as a duplicate of 68106 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo