Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 80208 - [Solaris] Fail to set String and Number value in Mapper
[Solaris] Fail to set String and Number value in Mapper
Status: VERIFIED FIXED
Product: soa
Classification: Unclassified
Component: BPEL Mapper
5.x
Sun Solaris
: P3 (vote)
: TBD
Assigned To: Alexey Anjeleevich
issues@soa
ENTPACK_55_BETA_RN 55EP_BETA_WAIVED 5...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-13 18:37 UTC by bugbridge
Modified: 2008-10-21 15:44 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Edit Mode (17.10 KB, image/png)
2006-07-17 19:29 UTC, _ hong_lin
Details
Non-edit mode (16.99 KB, image/png)
2006-07-17 19:30 UTC, _ hong_lin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bugbridge 2006-07-13 18:37:41 UTC
Original status: 9-Fix Failed; Suggested Status: REOPENED

Original Target Release: coke_dev; Suggested Target Milestone : 5.5

These items should be added to the Status Whiteboard: HOL
Original submitter: hong_lin

Description:

Machine: Ultra 20
OS: Solaris 10, x64

Steps t0 reproduce it:

1. Open a new SynchronousSample project.
2. Double-click the SynchronousSample.bpel node to open  the SynchronousSample 
diagram.
3. Drag an If activity to the design area between the start and assign 
activities.
4. In the Design view, click the If1 activity. The Mapper appears at the 
button of the IDE.
5. From the Method Palette, click the String method and select string literal 
from the String drop-down list. The string literal box appears in the editor.
6. Double-click the string literal box. The INPUT text field appear. But the 
cursor is missing. 
7. Type 'Hello World' in the string literal INPUT text field, none of the 
characters I typied is displayed in the INPUT text field. 
8. Hit "Enter" key.
9. Sometimes, the 'Hello World" is set to the string, sometimes it won't.
10. Got the same behavior when tired to set a Number value.

Note: 
1. This bug is reproduced on two Ultra 20 machine (Solaris 10, x64), one with 
JDK 1.5.0_06, one with JDK 1.5.0_01

2. This bug is also reproduced on a Sunblade 1000 (Solaris 10, Sparc-S2).

Evaluation:
this resulted from a platform-specific window sizing issue

i fixed this issue and now literal editing should work fine on Solaris 
(without causing any change to the current Windows behavior)
Comment 1 _ hong_lin 2006-07-17 19:25:37 UTC
Verified that the bug is fixed partially in build 200607130000.

After finishing step 1 to 5, The string literal box appeared in the editor. The
text field was ready to be edited. I typed string "Hello World" and hit "Enter"
key without error.

But when I tried to modify the string "Hello World", I couldn't edit the string
if I double-click the text field in the string literal box. The text field
changed to edit mode for one second (see attached snapshot EditMode.PNG) and
then back to non-edit mode (see attached snapeshot NonEditMode.PNG). Can't edit
anything.

But there is a walkaround:
Double-click the text field in the string literal box, then click a white place
inside the mapper editor field (for example, the red rectangle area in
EditMode.PNG file) quickly (before it turns back to non-edit mode). Then the
string literal box will stay in the edit mode. 






Comment 2 _ hong_lin 2006-07-17 19:29:28 UTC
Created attachment 31933 [details]
Edit Mode
Comment 3 _ hong_lin 2006-07-17 19:30:00 UTC
Created attachment 31934 [details]
Non-edit mode
Comment 4 Ed Wong 2006-08-19 01:02:04 UTC
Assign to self
Comment 5 Ed Wong 2006-08-26 02:30:12 UTC
After much research, I'm attributing this a JGo (used to render the Mapper
canvas) focus incompatibility issue with Unix and lowering to a P3 (with the
concurrence of another senior developer) because of the following:
1.  JGo will/should be phased out for the final release of the Mapper product
and thus the problem will be moot.
2.  There are workarounds:
  a.  If the field is double clicked to edit, use the keyboard buttons such as
Home, End, left/right arrows to navigate within the textfield
  b.  Use the right-click-->Edit method of editing the textfield.  If done this
way, the mouse can be used to navigate within the textfield as well as the
standard aforementioned keyboard buttons.
Comment 6 astashkova 2006-10-23 13:42:07 UTC
Added to RNs.

Use the following link to review the wording and location of the issue in the
staged  Release Notes
http://nbstaging.czech/community/releases/55/entpack_relnotes.html#80208
Comment 7 Jiri Prox 2007-09-17 20:22:46 UTC
Obsolete milestone, please reevaluate
Comment 8 Alexey Anjeleevich 2008-01-25 14:05:45 UTC
Fixed in new mapper core
Comment 9 ggenipudi 2008-10-21 15:44:43 UTC
tested and verified using NetBeans IDE 6.1 (Build 200810140114) and string field is editable.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo