Bug 78331 - CTRL-SHIFT-C doesn't work when focus in source or UML Documentation editor
CTRL-SHIFT-C doesn't work when focus in source or UML Documentation editor
Status: RESOLVED WONTFIX
Product: uml
Classification: Unclassified
Component: Design Center
5.x
PC Windows XP
: P3 (vote)
: 6.x
Assigned To: Yang Su
issues@uml
: A11Y, FOCUS
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-19 21:54 UTC by bugbridge
Modified: 2007-07-30 19:11 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bugbridge 2006-06-19 21:54:12 UTC
Original status: 1-Dispatched; Suggested Status: NEW

Description:
reproducible with buzz,coco,coke_tpr2 on win and solaris

steps to reproduce:
1. start IDE
2. open source editor and click in editor area
3. try CTRL-SHIFT-C
nothing happens
4. activate project tree
5. try CTRL-SHIFT-C
design center opens
Comment 1 Trey Spiva 2006-11-02 23:11:55 UTC
We are using the NB layer file to define this keystroke.  So, NetBeans is
responsible for handling the keystrokes.  I was able to reproduce this problem
with the versioning window.  If the navigator has the focus, the keystroke will
not open the versioning window.

The keystroke works for inside the editor, as well as inside the project tree. 
So, I do not understand why it does not work in the editor for the design center.

Since this seems to be a NetBeans core issues I am transfering the issue to
NetBeans.
Comment 2 Yang Su 2006-11-02 23:38:52 UTC
When focus is in source editor or documentation pane, CTRL-SHIFT-C is taken for
other actions defined in local context. It is inevitable to have key binding
conflict in a complicated application like IDE with individual modules defining
their own mapping. Assume we can find a key binding that is currently not used
in the IDE, it is impossible to guarantee that it will not clash with other
modules that users may download and install on their own.

Since we have had several releases with this shortcut mapped to design center,
it may not be wise to change it as users are getting used to the mapping. I
sugggest we leave it as is, since workaround exists, just shift focus to other
component, or invoke it from main menu.
Comment 3 Sergey Petrov 2006-11-03 09:10:46 UTC
I think users may never used this shortcut because of problems in many cases, so
we can change it in easy way (of cause it will require doc update).
And it's a bug if users should do additional steps to get result with any
shortcut, of cause it's P3 because workaround exists.
I can't agree with closing this bug, it's still a11y issue because of
not-standard way and usability issue, because user have to make additional
clicks instead of one.
Comment 4 Yang Su 2006-11-03 17:36:53 UTC
This key binding is implemented in a "configurable" fashion, meaning it can be
changed and re-mapped to whatever user specifies as long as it's valid. Just go
to tools ->options ->keymap->other->Design Center, and choose a keybinding that
you prefer.   It is now a standard way of resolving shortcut conflict if the
default does not work for the user.

How likely would it be for a user to want to bring up design center while he's
in the middle of editing a java source or uml documentation? If CTRL-SHIFT-C is
not that heavily loaded, we should not worry too much. 

But we are open for adopting a better ( or should I say, least favorite ) key
binding that hasn't been used anywhere in IDE. Suggestions are welcome.
Comment 5 Peter Lam 2006-11-13 17:05:03 UTC
Workaround: Windows->UML Modeling->Design Center
Comment 6 Yang Su 2007-07-30 19:11:44 UTC
will not fix based on the reasons given in previous comments.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo