Bug 78138 - Get InvocationTargetException if
Get InvocationTargetException if
Status: CLOSED FIXED
Product: soa
Classification: Unclassified
Component: BPEL
5.x
PC Windows XP
: P1 (vote)
: 5.x
Assigned To: Nikita Krjukov
issues@soa
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-16 15:22 UTC by bugbridge
Modified: 2006-08-31 02:00 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bugbridge 2006-06-16 15:22:35 UTC
Original status: 1-Dispatched; Suggested Status: NEW

These items should be added to the Keywords: REGRESSION
Original submitter: hong_lin

Description:
build: COke nightly build 060604

Note: Founction "Add CorrelationSet" works fine in Coke TPR3.

Steps to reproduce it:

1. Create a new BPEL Module BpelModule1.
2. Expand BpelModule1 -> Source Packages -> <default package>
3. Open BpelModule1.bpel into Enitor window.
4. In Design view, select the BPEL Process. Right-click. Select the "Add
CorrelationSet" item from the context menu.
5. Will get InvacationTargetException.

java.lang.reflect.InvocationTargetException
	at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
	at
sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
	at
sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
	at java.lang.reflect.Constructor.newInstance(Constructor.java:494)
	at
org.netbeans.modules.bpel.properties.editors.controls.SimpleCustomEditor.createContent(SimpleCustomEditor.java:69)
	at
org.netbeans.modules.bpel.properties.editors.controls.SimpleCustomEditor.<init>(SimpleCustomEditor.java:37)
[catch] at
org.netbeans.modules.bpel.properties.nodes.actions.AddCorrelationSetAction.performAction(AddCorrelationSetAction.java:79)
	at org.openide.util.actions.NodeAction.performAction(NodeAction.java:255)
	at
org.openide.util.actions.CallableSystemAction$1.run(CallableSystemAction.java:94)
	at
org.netbeans.modules.openide.util.ActionsBridge.doPerformAction(ActionsBridge.java:47)
	at
org.openide.util.actions.CallableSystemAction.actionPerformed(CallableSystemAction.java:90)
	at org.openide.util.actions.NodeAction.actionPerformed(NodeAction.java:244)
	at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:1849)
	at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2169)
	at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:420)
	at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:258)
	at javax.swing.AbstractButton.doClick(AbstractButton.java:302)
	at javax.swing.plaf.basic.BasicMenuItemUI.doClick(BasicMenuItemUI.java:1000)
	at
javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(BasicMenuItemUI.java:1041)
	at java.awt.Component.processMouseEvent(Component.java:5488)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3126)
	at java.awt.Component.processEvent(Component.java:5253)
	at java.awt.Container.processEvent(Container.java:1966)
	at java.awt.Component.dispatchEventImpl(Component.java:3955)
	at java.awt.Container.dispatchEventImpl(Container.java:2024)
	at java.awt.Component.dispatchEvent(Component.java:3803)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4212)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:3892)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:3822)
	at java.awt.Container.dispatchEventImpl(Container.java:2010)
	at java.awt.Window.dispatchEventImpl(Window.java:1774)
	at java.awt.Component.dispatchEvent(Component.java:3803)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:463)
	at
java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:242)
	at
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:163)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:157)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:149)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:110)
Caused by: java.util.MissingResourceException: Can't find bundle for base name
org/netbeans/modules/bpel/properties/editors/Form, locale en_US
	at java.util.ResourceBundle.throwMissingResourceException(ResourceBundle.java:836)
	at java.util.ResourceBundle.getBundleImpl(ResourceBundle.java:726)
	at java.util.ResourceBundle.getBundle(ResourceBundle.java:549)
	at
org.netbeans.modules.bpel.properties.editors.CorrelationSetMainPanel.initComponents(CorrelationSetMainPanel.java:129)
	at
org.netbeans.modules.bpel.properties.editors.CorrelationSetMainPanel.createContent(CorrelationSetMainPanel.java:51)
	at
org.netbeans.modules.bpel.properties.editors.CorrelationSetMainPanel.<init>(CorrelationSetMainPanel.java:42)
	... 38 more
==>
Annotation: Missing resource from class:
org/netbeans/modules/bpel/properties/editors/Form_en_US
Annotation: Key which was not found: 
java.util.MissingResourceException: Can't find bundle for base name
org/netbeans/modules/bpel/properties/editors/Form, locale en_US
	at java.util.ResourceBundle.throwMissingResourceException(ResourceBundle.java:836)
	at java.util.ResourceBundle.getBundleImpl(ResourceBundle.java:726)
	at java.util.ResourceBundle.getBundle(ResourceBundle.java:549)
	at
org.netbeans.modules.bpel.properties.editors.CorrelationSetMainPanel.initComponents(CorrelationSetMainPanel.java:129)
	at
org.netbeans.modules.bpel.properties.editors.CorrelationSetMainPanel.createContent(CorrelationSetMainPanel.java:51)
	at
org.netbeans.modules.bpel.properties.editors.CorrelationSetMainPanel.<init>(CorrelationSetMainPanel.java:42)
	at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
	at
sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
	at
sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
	at java.lang.reflect.Constructor.newInstance(Constructor.java:494)
	at
org.netbeans.modules.bpel.properties.editors.controls.SimpleCustomEditor.createContent(SimpleCustomEditor.java:69)
	at
org.netbeans.modules.bpel.properties.editors.controls.SimpleCustomEditor.<init>(SimpleCustomEditor.java:37)
[catch] at
org.netbeans.modules.bpel.properties.nodes.actions.AddCorrelationSetAction.performAction(AddCorrelationSetAction.java:79)
	at org.openide.util.actions.NodeAction.performAction(NodeAction.java:255)
	at
org.openide.util.actions.CallableSystemAction$1.run(CallableSystemAction.java:94)
	at
org.netbeans.modules.openide.util.ActionsBridge.doPerformAction(ActionsBridge.java:47)
	at
org.openide.util.actions.CallableSystemAction.actionPerformed(CallableSystemAction.java:90)
	at org.openide.util.actions.NodeAction.actionPerformed(NodeAction.java:244)
	at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:1849)
	at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2169)
	at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:420)
	at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:258)
	at javax.swing.AbstractButton.doClick(AbstractButton.java:302)
	at javax.swing.plaf.basic.BasicMenuItemUI.doClick(BasicMenuItemUI.java:1000)
	at
javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(BasicMenuItemUI.java:1041)
	at java.awt.Component.processMouseEvent(Component.java:5488)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3126)
	at java.awt.Component.processEvent(Component.java:5253)
	at java.awt.Container.processEvent(Container.java:1966)
	at java.awt.Component.dispatchEventImpl(Component.java:3955)
	at java.awt.Container.dispatchEventImpl(Container.java:2024)
	at java.awt.Component.dispatchEvent(Component.java:3803)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4212)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:3892)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:3822)
	at java.awt.Container.dispatchEventImpl(Container.java:2010)
	at java.awt.Window.dispatchEventImpl(Window.java:1774)
	at java.awt.Component.dispatchEvent(Component.java:3803)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:463)
	at
java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:242)
	at
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:163)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:157)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:149)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:110)
Comment 1 Nikita Krjukov 2006-07-07 12:45:11 UTC
I can't reproduce the issue
Comment 2 _ hong_lin 2006-07-27 01:42:48 UTC
Verified the bug is fixed in nightly build 060725


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo