Bug 78088 - Exception when clicking on Catch element on diagram
Exception when clicking on Catch element on diagram
Status: VERIFIED FIXED
Product: soa
Classification: Unclassified
Component: BPEL
5.x
PC Windows XP
: P1 (vote)
: 5.x
Assigned To: Nikita Krjukov
issues@soa
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-16 14:39 UTC by bugbridge
Modified: 2006-08-31 02:00 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bugbridge 2006-06-16 14:39:52 UTC
Original status: 1-Dispatched; Suggested Status: NEW

Original Target Release: coke_dev; Suggested Target Milestone : 5.5

Original submitter: apepin

Description:
Steps to reproduce:
- create a new BPEL Module project
- open bpel in designer
- add Fault handlers to Process
- add Catch to Process
- click on Catch element
Result: IllegalAccessException appears:
java.lang.IllegalAccessException: Class
org.openide.nodes.PropertySupport$Reflection can not access a member of class
org.netbeans.modules.bpel.properties.props.editors.StringPropEditor with
modifiers "protected"
	at sun.reflect.Reflection.ensureMemberAccess(Reflection.java:65)
	at java.lang.Class.newInstance0(Class.java:344)
	at java.lang.Class.newInstance(Class.java:303)
	at
org.openide.nodes.PropertySupport$Reflection.getPropertyEditor(PropertySupport.java:305)
	at
org.openide.explorer.propertysheet.PropUtils.getPropertyEditor(PropUtils.java:806)
	at
org.openide.explorer.propertysheet.ReusablePropertyModel.getPropertyEditor(ReusablePropertyModel.java:73)
	at
org.openide.explorer.propertysheet.RendererFactory.preparePropertyEditor(RendererFactory.java:210)
	at
org.openide.explorer.propertysheet.RendererFactory.getRenderer(RendererFactory.java:117)
	at
org.openide.explorer.propertysheet.SheetCellRenderer.getTableCellRendererComponent(SheetCellRenderer.java:123)
	at org.openide.explorer.propertysheet.BaseTable.prepareRenderer(BaseTable.java:597)
	at
org.openide.explorer.propertysheet.SheetTable.prepareRenderer(SheetTable.java:507)
	at javax.swing.plaf.basic.BasicTableUI.paintCell(BasicTableUI.java:2070)
	at javax.swing.plaf.basic.BasicTableUI.paintCells(BasicTableUI.java:1972)
	at javax.swing.plaf.basic.BasicTableUI.paint(BasicTableUI.java:1895)
	at javax.swing.plaf.ComponentUI.update(ComponentUI.java:142)
	at javax.swing.JComponent.paintComponent(JComponent.java:742)
	at org.openide.explorer.propertysheet.BaseTable.paintComponent(BaseTable.java:959)
	at
org.openide.explorer.propertysheet.SheetTable.paintComponent(SheetTable.java:413)
	at javax.swing.JComponent.paint(JComponent.java:1005)
	at org.openide.explorer.propertysheet.BaseTable.paint(BaseTable.java:647)
	at javax.swing.JComponent.paintChildren(JComponent.java:842)
	at javax.swing.JComponent.paint(JComponent.java:1014)
	at javax.swing.JViewport.paint(JViewport.java:728)
	at javax.swing.JComponent.paintChildren(JComponent.java:842)
	at javax.swing.JComponent.paint(JComponent.java:1014)
	at javax.swing.JComponent.paintWithOffscreenBuffer(JComponent.java:4963)
	at javax.swing.JComponent.paintDoubleBuffered(JComponent.java:4916)
	at javax.swing.JComponent._paintImmediately(JComponent.java:4859)
	at javax.swing.JComponent.paintImmediately(JComponent.java:4666)
	at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:451)
[catch] at
javax.swing.SystemEventQueueUtilities$ComponentWorkRequest.run(SystemEventQueueUtilities.java:114)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:461)
	at
java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:242)
	at
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:163)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:157)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:149)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:110)
Comment 1 Nikita Krjukov 2006-07-07 12:31:41 UTC
The properties of the Catch element has been refactored. 
The issue isn't reproduced after it. 
Comment 2 Nikita Krjukov 2006-07-07 12:32:12 UTC
The properties of the Catch element has been refactored. 
The issue isn't reproduced after it. 
Comment 3 Nikita Krjukov 2006-07-07 12:32:46 UTC
The properties of the Catch element has been refactored. 
The issue isn't reproduced after it. 
Comment 4 Mikhail Kondratyev 2006-07-24 13:13:19 UTC
Verified in build from 060723


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo