Bug 78077 - No Such Method exception when double-clicking on receive element
No Such Method exception when double-clicking on receive element
Status: VERIFIED FIXED
Product: soa
Classification: Unclassified
Component: BPEL
5.x
PC Windows XP
: P1 (vote)
: 5.x
Assigned To: Nikita Krjukov
issues@soa
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-16 14:22 UTC by bugbridge
Modified: 2006-08-31 02:01 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bugbridge 2006-06-16 14:22:28 UTC
Original status: 1-Dispatched; Suggested Status: NEW

Original Target Release: coke_dev; Suggested Target Milestone : 5.5

Original submitter: mikk

Description:
Tested with build 20060514
Steps to reproduce:
 - create a BPEL module
 - open BPEL in designer
 - add Receive activity from palette
 - double click on the Receive activity
Exception will be shown:
java.lang.NoSuchMethodException:
org.netbeans.modules.bpel.model.api.Receive.setMessageExchange(java.lang.String)
	at java.lang.Class.getMethod(Class.java:1581)
	at
org.netbeans.modules.bpel.properties.props.PropertyUtils$Reflection.<init>(PropertyUtils.java:394)
	at
org.netbeans.modules.bpel.properties.props.PropertyUtils.registerPropertyImpl(PropertyUtils.java:118)
	at
org.netbeans.modules.bpel.properties.props.PropertyUtils.registerAttributeProperty(PropertyUtils.java:90)
	at
org.netbeans.modules.bpel.properties.nodes.ReceiveNode.createSheet(ReceiveNode.java:113)
	at org.openide.nodes.AbstractNode.getSheet(AbstractNode.java:398)
	at org.openide.nodes.AbstractNode.getPropertySets(AbstractNode.java:409)
	at
org.netbeans.modules.bpel.properties.props.PropertyUtils.lookForPropertyByBoundedAttribute(PropertyUtils.java:279)
	at
org.netbeans.modules.bpel.properties.nodes.BpelNode.updateAttributeProperty(BpelNode.java:240)
	at
org.netbeans.modules.bpel.properties.nodes.BpelNode$Synchronizer.notifyEvent(BpelNode.java:367)
	at
org.netbeans.modules.bpel.model.api.events.ChangeEventListenerAdapter.notifyPropertyUpdated(ChangeEventListenerAdapter.java:58)
	at
org.netbeans.modules.bpel.model.api.events.ChangeEventSupport.notifyChangeEvent(ChangeEventSupport.java:172)
	at
org.netbeans.modules.bpel.model.api.events.ChangeEventSupport.fireChangeEvent(ChangeEventSupport.java:148)
	at
org.netbeans.modules.bpel.model.impl.BpelModelImpl$Transaction.commitEvents(BpelModelImpl.java:700)
	at
org.netbeans.modules.bpel.model.impl.BpelModelImpl$Transaction.end(BpelModelImpl.java:615)
	at
org.netbeans.modules.bpel.model.impl.BpelModelImpl.writeUnlock(BpelModelImpl.java:366)
	at
org.netbeans.modules.bpel.model.impl.BpelModelImpl.invoke(BpelModelImpl.java:165)
	at
org.netbeans.modules.bpel.properties.editors.controls.AbstractCustomNodeEditor.applyNewValues(AbstractCustomNodeEditor.java:156)
	at
org.netbeans.modules.bpel.properties.editors.controls.AbstractCustomNodeEditor.doValidateAndSave(AbstractCustomNodeEditor.java:229)
	at
org.netbeans.modules.bpel.properties.editors.controls.valid.NodeEditorDescriptor.processOkButton(NodeEditorDescriptor.java:98)
	at
org.netbeans.modules.bpel.properties.editors.controls.valid.NodeEditorDescriptor$1.actionPerformed(NodeEditorDescriptor.java:55)
	at
org.netbeans.core.windows.services.NbPresenter$ButtonListener.actionPerformed(NbPresenter.java:1074)
	at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:1849)
	at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2169)
	at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:420)
	at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:258)
	at
javax.swing.plaf.basic.BasicButtonListener.mouseReleased(BasicButtonListener.java:234)
	at java.awt.Component.processMouseEvent(Component.java:5488)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3126)
	at java.awt.Component.processEvent(Component.java:5253)
	at java.awt.Container.processEvent(Container.java:1966)
	at java.awt.Component.dispatchEventImpl(Component.java:3955)
	at java.awt.Container.dispatchEventImpl(Container.java:2024)
	at java.awt.Component.dispatchEvent(Component.java:3803)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4212)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:3892)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:3822)
	at java.awt.Container.dispatchEventImpl(Container.java:2010)
	at java.awt.Window.dispatchEventImpl(Window.java:1774)
	at java.awt.Component.dispatchEvent(Component.java:3803)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:463)
	at
java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:242)
	at
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:163)
	at
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:153)
	at java.awt.Dialog$1.run(Dialog.java:515)
	at java.awt.Dialog.show(Dialog.java:536)
	at org.netbeans.core.windows.services.NbPresenter.superShow(NbPresenter.java:810)
	at org.netbeans.core.windows.services.NbPresenter.doShow(NbPresenter.java:853)
	at org.netbeans.core.windows.services.NbPresenter.run(NbPresenter.java:841)
	at org.openide.util.Mutex.doEventAccess(Mutex.java:1172)
	at org.openide.util.Mutex.readAccess(Mutex.java:209)
	at org.netbeans.core.windows.services.NbPresenter.show(NbPresenter.java:826)
	at java.awt.Component.show(Component.java:1300)
	at java.awt.Component.setVisible(Component.java:1253)
	at
org.netbeans.modules.bpel.properties.PropertyNodeFactory.showNodeCustomEditor(PropertyNodeFactory.java:344)
	at
org.netbeans.modules.bpel.navigator.nodes.NavigatorNodeFactory.showNodeCustomEditor(NavigatorNodeFactory.java:133)
	at
org.netbeans.modules.bpel.design.DesignView.showCustomEditor(DesignView.java:344)
	at
org.netbeans.modules.bpel.design.MouseHandler.mouseClicked(MouseHandler.java:102)
	at java.awt.AWTEventMulticaster.mouseClicked(AWTEventMulticaster.java:211)
	at java.awt.AWTEventMulticaster.mouseClicked(AWTEventMulticaster.java:211)
	at java.awt.Component.processMouseEvent(Component.java:5491)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3126)
	at java.awt.Component.processEvent(Component.java:5253)
	at java.awt.Container.processEvent(Container.java:1966)
	at java.awt.Component.dispatchEventImpl(Component.java:3955)
	at java.awt.Container.dispatchEventImpl(Container.java:2024)
	at java.awt.Component.dispatchEvent(Component.java:3803)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4212)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:3901)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:3822)
	at java.awt.Container.dispatchEventImpl(Container.java:2010)
	at java.awt.Window.dispatchEventImpl(Window.java:1774)
	at java.awt.Component.dispatchEvent(Component.java:3803)
[catch] at java.awt.EventQueue.dispatchEvent(EventQueue.java:463)
	at
java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:242)
	at
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:163)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:157)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:149)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:110)
Comment 1 Nikita Krjukov 2006-07-07 12:36:07 UTC
I can't reproduce the issue now. 
It seems I have already fixed it. 
Comment 2 Mikhail Kondratyev 2006-07-24 13:09:02 UTC
Verified in build 060723


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo