Bug 77255 - IllegalStateException after plugging in Nokia Carbide.j
IllegalStateException after plugging in Nokia Carbide.j
Status: VERIFIED DUPLICATE of bug 91306
Product: javame
Classification: Unclassified
Component: -- Other --
5.x
All All
: P3 (vote)
: TBD
Assigned To: issues@soa
issues@mobility
NOKIA_CARBIDE
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-01 20:31 UTC by jxt
Modified: 2009-01-12 11:44 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
messages.log file containing the exception (31.23 KB, text/plain)
2006-06-01 20:32 UTC, jxt
Details
messages.log (212.34 KB, text/plain)
2007-01-13 23:38 UTC, shamatt
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jxt 2006-06-01 20:31:19 UTC
After plugging in the Nokia Carbide.j tool into NB 5.5beta, I get an 
IllegalStateException during startup. I'll attach the messages.log file, which 
starts out with some warnings about Nokia and OpenIDE and something in use 
being deprecated.

Interestingly, these same messages appear in the NB 5.0 log file after 
plugging in Carbide.j. The IllegalStateException occurs later. It occurs only 
in NB 5.5beta, not 5.0.
Comment 1 jxt 2006-06-01 20:32:31 UTC
Created attachment 30730 [details]
messages.log file containing the exception
Comment 2 Lukas Hasik 2006-06-05 14:37:07 UTC
it doesn't seem like MP problem for me. The exception is coming from
om.nokia.phone.tools.designer.integration.netbeans.NetBeansIntegrationModuleInstall.addJDOActions
    and ISE[CNFE] from SOA.

Reassigning...

[org.netbeans.core.modules] *********** Exception occurred ************ at 2:58
PM on Jun 1, 2006
java.lang.IllegalStateException: java.lang.ClassNotFoundException:
org.netbeans.modules.soa.orch.bp.BusinessProcessDataObject
	at org.openide.loaders.DataLoader.getRepresentationClass(DataLoader.java:119)
	at org.openide.loaders.DataLoaderPool$1ProducerOf.process(DataLoaderPool.java:324)
	at org.openide.util.Enumerations$FilEn.hasMoreElements(Enumerations.java:523)
	at
com.nokia.phone.tools.designer.integration.netbeans.NetBeansIntegrationModuleInstall.addJDOActions(Unknown
Source)
	at
com.nokia.phone.tools.designer.integration.netbeans.NetBeansIntegrationModuleInstall.restored(Unknown
Source)
Comment 3 jxt 2006-06-05 14:45:02 UTC
I am the original poster of this issue. The point is, I believe, the 
regression, since this exception occurs in NB 5.5 beta but not in NB 5.0. Yes, 
it's occuring in 3rd-party code, but something has changed in NB 5.5 and/or 
MobilityPack 5.5 (or *somewhere*) that causes the Nokia Carbide.j plugin to 
fail in 5.5 but not in 5.0.
Comment 4 Martin Ryzl 2006-06-05 14:57:16 UTC
Looking at the stack trace it is somewhere between Nokia Carbide and Enterprise
Pack and I believe if you have NB only with Ent. Pack and Carbide (without
Mobility Pack) you'll get the same exception. The purpose of reassigning is to
notify people who may know more details.
Comment 5 Sreenivasan Genipudi 2006-09-06 02:57:19 UTC
Please re test using latest builds.
Comment 6 Lukas Hasik 2006-09-06 12:29:39 UTC
what do you mean by "Please re test using latest builds." ?
Latest builds of what? Carbide.j? NetBeans? Mobility Pack? Enterprise Pack?

Was it fixed? What is Target Milestone for this issue? 5.5? 6.0==trunk?

thank you for explanation.
Comment 7 Ritesh Adval 2006-09-08 00:59:22 UTC
org.netbeans.modules.soa.orch.bp.BusinessProcessDataObject

bpel edior data object problem. reassigning.
Comment 8 Denis Anisimov 2006-09-08 08:26:24 UTC
I'm absolutely sure that currently this cannot be reproducable.
Class BusinessProcessDataObject doesn't have any mentions in current source
code of BPEL project. 
This exception could appear only in the case of cached ( serialized ) objects
or old build.

So for avoiding this bug you need:
1) clean your ".netbeans" folder in your home directory.
2) reinstall NB with ent pack or remove current netbeans folder and perform 
clean build from scratch from sources.
Comment 9 Alexey Yarmolenko 2006-09-08 19:56:19 UTC
"org.netbeans.modules.soa.orch" is a package naming used in old versions of 
EntPack. Starting March 2006 all code from these packages was moved 
to "org.netbeans.modules.bpel". 

I searched thru all soa modules in current ent pack and found 0 usages of this 
names.

Please try to follow Denis's recomendations and then update status for this 
bug.
Comment 10 Michael Frisino 2006-09-12 12:09:07 UTC
latest build means latest build of NetBeans 5.5 plus latest build of Enterprise
pack.
Comment 11 shamatt 2007-01-13 23:36:36 UTC
Same problem, different object.  I just installed Carbide.j 1.5 and get the 
following Exception at every startup of NetBeans 5.5 with mobility pack.  JDK 
1.6.0.

The following was cut and pasted from the message box.  Will also attach 
messages.log.

java.lang.IllegalStateException: java.lang.ClassNotFoundException: 
org.netbeans.modules.websvc.core.customization.ui.WSDataObject
	at org.openide.loaders.DataLoader.getRepresentationClass
(DataLoader.java:125)
	at org.openide.loaders.DataLoaderPool$1ProducerOf.process
(DataLoaderPool.java:330)
	at org.openide.util.Enumerations$FilEn.hasMoreElements
(Enumerations.java:529)
	at 
com.nokia.phone.tools.designer.integration.netbeans.NetBeansIntegrationModuleIn
stall.addJDOActions(Unknown Source)
	at 
com.nokia.phone.tools.designer.integration.netbeans.NetBeansIntegrationModuleIn
stall.restored(Unknown Source)
	at org.netbeans.core.startup.NbInstaller.loadCode(NbInstaller.java:366)
.
.
.
Comment 12 shamatt 2007-01-13 23:38:49 UTC
Created attachment 37346 [details]
messages.log
Comment 13 Lukas Hasik 2007-01-22 08:38:17 UTC
the java.lang.IllegalStateException: java.lang.ClassNotFoundException: 
org.netbeans.modules.websvc.core.customization.ui.WSDataObject is definitelly
caused by integration with Nokia Carbide.J . The ISE is duplicate of issue 91306
Comment 14 Alexey Yarmolenko 2007-02-08 14:45:29 UTC
Exceptions are not the same. Exception in 2nd log occurs in different place for
different object. According to stacktrace, execution is not going thru Entpack
code. Please move this bug to mobility pack category.
Comment 15 Lukas Hasik 2007-02-13 08:49:33 UTC
closing as duplicate

*** This issue has been marked as a duplicate of 91306 ***
Comment 16 Ivan Sidorkin 2009-01-12 11:44:16 UTC
verified


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo