Bug 76837 - Class diagram creation corrupts project structure
Class diagram creation corrupts project structure
Status: CLOSED INVALID
Product: uml
Classification: Unclassified
Component: Diagram Class
5.x
PC Windows XP
: P1 (vote)
: TBD
Assigned To: Trey Spiva
issues@uml
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-25 00:49 UTC by seanl
Modified: 2006-08-02 08:28 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description seanl 2006-05-25 00:49:27 UTC
I followed the tutorial at http://www.netbeans.org/kb/55/uml_fe.html. Here are
the steps in question with my comments interspersed:
------------------------
Creating the UML Project and the Class Diagram

In this section, you create the UML project and class diagram for the application.

   1. To create the UML project, choose File > New Project and then do the
following:
         1. Under Categories, select UML.
         2. Under Projects, select Java-Platform Model.
         3. Click Next.
The New Java-Platform Model page opens.
   2. In the Project Name field, type UMLPrj.

      Notice that when you type the Project Name, the IDE automatically suggests
this name for the name of the Project Folder.
   3. Verify that the Project Location is MyPrj.
   4. Select the Generate Code checkbox and click Next.
   5. In the Choose the Java Source Project page, verify that JavaPrj is
selected from the Java Project drop-down list.
   6. Click Finish.

>>>>> At this point, the UMLPrj has a Models and Diagrams folder.

      The IDE creates the UML project and the New Wizard opens and displays the
Create New Diagram dialog box.
   7. In the Diagram Type list, select Class Diagram.
   8. In the Diagram Name field, type BankClassDiagram.
   9. Leave UMLPrj in the Namespace field and click OK.

>>>>> After this, the Models and Diagrams folders are gone and under the UMLPrj
are the following files:
nbproject (folder)
BankClassDiagram_1148512861741.etld
BankClassDiagram_1148512861741.etlp
UMLPrj.etd
UMLPrj.ettm
UML_2.0EMBT.dtd

If I close the BankClassDiagram, there is no way (that I can find) to reopen it.
 A variant is to cancel the Create New Diagram Dialog box. At that point, the
Models and Diagrams folders are present. If I try to add a diagram, I get the
same results as above.
Comment 1 Peter Lam 2006-05-26 00:44:04 UTC
This is a very strange issue that I have not seen myself at all.
I can't reproduce this and not sure which platform this was happening from since
it's indicated as All for both Platform and OS.

After step 6, the tool should not have not created the Models and Diagram
folders on the project tree, not even the uml project until a diagram is
selected to create first. From the filesystem, I sure see nbproject folder but
there's no Diagram folder as indicated. So, what's indicated in the description
doesn't make sense to me. Please provide more detail as to which platform and OS
and additional detail would be helpful.
Comment 2 seanl 2006-05-26 13:18:46 UTC
I must clarify. I said that after step 6, the UMLPrj has a Models and Diagrams
folder. I only verified this in the case where, in step 7 I press "cancel"
instead of selecting to create a class diagram in the Create New Diagram Dialog.
My previous description may have led one to believe that after completing step
6, these folders appeared. 


Comment 3 seanl 2006-05-27 22:55:10 UTC
I was using 5.5 preview which is different than 5.5 beta. The problem does not
exist in beta.
Comment 4 Peter Lam 2006-08-02 08:28:22 UTC
invalid bug


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo