Bug 76198 - Dead lock leading to deletion of sources in sprint edition
Dead lock leading to deletion of sources in sprint edition
Status: RESOLVED DUPLICATE of bug 73091
Product: java
Classification: Unclassified
Component: Unsupported
5.x
All All
: P2 (vote)
: TBD
Assigned To: Jan Becicka
issues@java
SPRINT_IDE
: THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-11 10:04 UTC by luky
Modified: 2007-09-26 09:14 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Stack dump (31.93 KB, text/plain)
2006-05-11 10:05 UTC, luky
Details
Excerpt of the thread dump that seems to be the cause of deadlock (5.82 KB, text/plain)
2006-05-12 19:08 UTC, Adam Sotona
Details

Note You need to log in before you can comment on or make changes to this bug.
Description luky 2006-05-11 10:04:16 UTC
Hi,
Sometimes, after long working time(few hours), when trying to save the edited 
files, the application stopped.
When it happened you can release the application only by closing it from the 
task manager.
This situation cleans all the project files, the files are empty.
Thanks,
Eyal.

--
Comment 1 luky 2006-05-11 10:05:33 UTC
Created attachment 30331 [details]
Stack dump
Comment 2 Adam Sotona 2006-05-12 19:06:13 UTC
The deadlock on MDR transaction seems to be between Scanning Queue and Folder
Recognizer.

I am re-assigning this deadlock to Java module because by the quick overview the
reason might be the synchronous actions taken by JavaParserGlue when kicked by
property change of DataObject.
Comment 3 Adam Sotona 2006-05-12 19:08:07 UTC
Created attachment 30381 [details]
Excerpt of the thread dump that seems to be the cause of deadlock
Comment 4 Jan Becicka 2006-06-13 10:20:45 UTC
Is it reproducible in 5.5?
The stacktrace is really different from current source.
Comment 5 Jan Becicka 2006-06-14 09:22:49 UTC

*** This issue has been marked as a duplicate of 73091 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo