Bug 75717 - space in value of TMPDIR breaks startup
space in value of TMPDIR breaks startup
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: -- Other --
5.x
All Linux
: P2 (vote)
: 5.x
Assigned To: Jaroslav Tulach
issues@platform
5.5_fix
: REGRESSION, SPACE_IN_PATH
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-28 21:51 UTC by Vince Kraemer
Modified: 2008-12-22 23:08 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Changes to the license (1.16 KB, patch)
2006-06-12 14:56 UTC, Jaroslav Tulach
Details | Diff
The launcher, please try it with 5.5 (10.75 KB, text/plain)
2006-06-12 14:59 UTC, Jaroslav Tulach
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vince Kraemer 2006-04-28 21:51:20 UTC
I set the value of the environment variable TMPDIR to "/home/vbk/space test/".

I see this when i try to run netbeans...

vbk@ubuntuabihsot:~/release55$ nbbuild/netbeans/bin/netbeans -userdir ~/nb55ud/28a
Exception in thread "main" java.lang.NoClassDefFoundError: test//nbenv/5794
Comment 1 Marian Mirilovic 2006-05-04 15:38:53 UTC
You are right, it's reproducible NB 5.5 (200605031130) but it works fine in NB
dev  (200605031800) !
Comment 2 Antonin Nebuzelsky 2006-06-06 13:24:03 UTC
Jardo, can you evaluate?
Comment 3 Jaroslav Tulach 2006-06-12 14:56:41 UTC
Created attachment 30974 [details]
Changes to the license
Comment 4 Jaroslav Tulach 2006-06-12 14:59:41 UTC
Created attachment 30975 [details]
The launcher, please try it with 5.5
Comment 5 Jaroslav Tulach 2006-06-14 15:44:10 UTC
Enclosing TMPDIR in \""
cvs commit: Examining .
Checking in nbexec;
/cvs/core/launcher/unix/nbexec,v  <--  nbexec
new revision: 1.24.18.1.2.2; previous revision: 1.24.18.1.2.1
Comment 6 Jesse Glick 2006-06-14 15:46:28 UTC
Works in dev builds without patch because we can rely on JDK 5's System.getenv()
instead of launcher hacks, I guess.
Comment 7 Jaroslav Tulach 2006-06-14 16:03:58 UTC
Right. No need to fix in trunk.
Comment 8 Tomas Danek 2006-10-02 13:21:23 UTC
could not reproduce in 5.5 20061002, jdk 1.5.0_09, temp dir set to /tmp/aa bb 
-> verified


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo