Bug 75477 - AIOOBE when running project with Windows UNC paths
AIOOBE when running project with Windows UNC paths
Status: RESOLVED DUPLICATE of bug 46813
Product: java
Classification: Unclassified
Component: Project
5.x
PC Windows XP
: P2 (vote)
: 6.x
Assigned To: Tomas Zezula
issues@java
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-25 11:53 UTC by ad
Modified: 2006-10-23 16:40 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ad 2006-04-25 11:53:38 UTC
On attempting to run small test program, on a mapped drive, having copied 
project from C: drive and resolved reference problem to src folder

java.lang.ArrayIndexOutOfBoundsException: 0
	at 
org.netbeans.modules.java.j2seproject.J2SEActionProvider.isSetMainClass
(J2SEActionProvider.java:568)
	at 
org.netbeans.modules.java.j2seproject.J2SEActionProvider.getTargetNames
(J2SEActionProvider.java:278)
	at org.netbeans.modules.java.j2seproject.J2SEActionProvider$1.run
(J2SEActionProvider.java:185)
	at 
org.netbeans.modules.javacore.internalapi.JavaMetamodel.invokeAfterScanFinished
(JavaMetamodel.java:209)
	at 
org.netbeans.modules.java.j2seproject.J2SEActionProvider.invokeAction
(J2SEActionProvider.java:214)
	at 
org.netbeans.modules.project.ui.actions.MainProjectAction.actionPerformed
(MainProjectAction.java:91)
	at javax.swing.AbstractButton.fireActionPerformed
(AbstractButton.java:1849)
	at javax.swing.AbstractButton$Handler.actionPerformed
(AbstractButton.java:2169)
	at javax.swing.DefaultButtonModel.fireActionPerformed
(DefaultButtonModel.java:420)
	at javax.swing.DefaultButtonModel.setPressed
(DefaultButtonModel.java:258)
	at javax.swing.plaf.basic.BasicButtonListener.mouseReleased
(BasicButtonListener.java:234)
	at java.awt.AWTEventMulticaster.mouseReleased
(AWTEventMulticaster.java:231)
	at java.awt.AWTEventMulticaster.mouseReleased
(AWTEventMulticaster.java:231)
	at java.awt.Component.processMouseEvent(Component.java:5488)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3126)
	at java.awt.Component.processEvent(Component.java:5253)
	at java.awt.Container.processEvent(Container.java:1966)
	at java.awt.Component.dispatchEventImpl(Component.java:3955)
	at java.awt.Container.dispatchEventImpl(Container.java:2024)
	at java.awt.Component.dispatchEvent(Component.java:3803)
	at java.awt.LightweightDispatcher.retargetMouseEvent
(Container.java:4212)
	at java.awt.LightweightDispatcher.processMouseEvent
(Container.java:3892)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:3822)
	at java.awt.Container.dispatchEventImpl(Container.java:2010)
	at java.awt.Window.dispatchEventImpl(Window.java:1774)
	at java.awt.Component.dispatchEvent(Component.java:3803)
[catch] at java.awt.EventQueue.dispatchEvent(EventQueue.java:463)
	at java.awt.EventDispatchThread.pumpOneEventForHierarchy
(EventDispatchThread.java:242)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy
(EventDispatchThread.java:163)
	at java.awt.EventDispatchThread.pumpEvents
(EventDispatchThread.java:157)
	at java.awt.EventDispatchThread.pumpEvents
(EventDispatchThread.java:149)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:110)


On trying to look at project properties

java.lang.IllegalArgumentException: URI has an authority component
	at java.io.File.<init>(File.java:340)
	at 
org.netbeans.modules.java.j2seproject.ui.customizer.J2SESourceRootsUi.createMod
el(J2SESourceRootsUi.java:67)
	at 
org.netbeans.modules.java.j2seproject.ui.customizer.J2SEProjectProperties.init
(J2SEProjectProperties.java:237)
	at 
org.netbeans.modules.java.j2seproject.ui.customizer.J2SEProjectProperties.<init
>(J2SEProjectProperties.java:227)
	at 
org.netbeans.modules.java.j2seproject.ui.customizer.CustomizerProviderImpl.show
Customizer(CustomizerProviderImpl.java:94)
	at 
org.netbeans.modules.java.j2seproject.ui.customizer.CustomizerProviderImpl.show
Customizer(CustomizerProviderImpl.java:83)
	at 
org.netbeans.modules.java.j2seproject.ui.customizer.CustomizerProviderImpl.show
Customizer(CustomizerProviderImpl.java:78)
	at 
org.netbeans.modules.project.ui.actions.CustomizeProject.actionPerformed
(CustomizeProject.java:70)
	at 
org.netbeans.modules.project.ui.actions.LookupSensitiveAction.actionPerformed
(LookupSensitiveAction.java:100)
	at javax.swing.AbstractButton.fireActionPerformed
(AbstractButton.java:1849)
	at javax.swing.AbstractButton$Handler.actionPerformed
(AbstractButton.java:2169)
	at javax.swing.DefaultButtonModel.fireActionPerformed
(DefaultButtonModel.java:420)
	at javax.swing.DefaultButtonModel.setPressed
(DefaultButtonModel.java:258)
	at javax.swing.AbstractButton.doClick(AbstractButton.java:302)
	at javax.swing.plaf.basic.BasicMenuItemUI.doClick
(BasicMenuItemUI.java:1000)
	at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased
(BasicMenuItemUI.java:1041)
	at java.awt.AWTEventMulticaster.mouseReleased
(AWTEventMulticaster.java:231)
	at java.awt.Component.processMouseEvent(Component.java:5488)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3126)
	at java.awt.Component.processEvent(Component.java:5253)
	at java.awt.Container.processEvent(Container.java:1966)
	at java.awt.Component.dispatchEventImpl(Component.java:3955)
	at java.awt.Container.dispatchEventImpl(Container.java:2024)
	at java.awt.Component.dispatchEvent(Component.java:3803)
	at java.awt.LightweightDispatcher.retargetMouseEvent
(Container.java:4212)
	at java.awt.LightweightDispatcher.processMouseEvent
(Container.java:3892)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:3822)
	at java.awt.Container.dispatchEventImpl(Container.java:2010)
	at java.awt.Window.dispatchEventImpl(Window.java:1774)
	at java.awt.Component.dispatchEvent(Component.java:3803)
[catch] at java.awt.EventQueue.dispatchEvent(EventQueue.java:463)
	at java.awt.EventDispatchThread.pumpOneEventForHierarchy
(EventDispatchThread.java:242)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy
(EventDispatchThread.java:163)
	at java.awt.EventDispatchThread.pumpEvents
(EventDispatchThread.java:157)
	at java.awt.EventDispatchThread.pumpEvents
(EventDispatchThread.java:149)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:110)
Comment 1 Milan Kubec 2006-05-02 10:53:20 UTC
The project seems to be somehow misconfigured (no source root), please describe
exactly what you were doing and also how your network is set up (as you wrote
mapped drive). Do you use windows UNC path names? What JDK do you use? Thanks.
Comment 2 Milan Kubec 2006-05-02 11:15:40 UTC
Response from user:

I set up the project on a laptop (where it ran fine) and then copied the
project folder to a pc. This then told me the sources were missing, so
I resolved references to point to the location of the src folder. That
got rid of that warning, and then the problems occurred.
Comment 3 Milan Kubec 2006-05-02 11:22:27 UTC
OK. Do you have project with external source root? Did you fix the broken
reference the way that it points to location on laptop? Can you build the
project? Would be possible to zip up the project and send it to me directly?
Comment 4 Milan Kubec 2006-05-04 12:10:31 UTC
User sent me the project and it uses Windows UNC paths that are not supported by
NetBeans. Sorry.

*** This issue has been marked as a duplicate of 46813 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo