Bug 73577 - "Minimize Field Access" throws EngineException
"Minimize Field Access" throws EngineException
Status: RESOLVED FIXED
Product: contrib
Classification: Unclassified
Component: Jackpot
5.x
PC Windows XP
: P2 (vote)
: TBD
Assigned To: issues@contrib
issues@contrib
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-14 19:35 UTC by _ alexlamsl
Modified: 2006-03-14 20:40 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description _ alexlamsl 2006-03-14 19:35:46 UTC
with the same setup as issue #73557 and the updated Jackpot module as of 
03/13, performing Tranform --> Minimize Field Access throws EngineException:

org.netbeans.jackpot.engine.EngineException: Error executing operator
	at org.netbeans.jackpot.builder.Engine.runCommand(Engine.java:119)
	at org.netbeans.modules.jackpot.JackpotModule.runCommand
(JackpotModule.java:132)
	at org.netbeans.modules.jackpot.actions.JackpotAction$CommandRunner.run
(JackpotAction.java:77)
[catch] at java.lang.Thread.run(Thread.java:626)
Caused by: java.lang.AssertionError
	at org.netbeans.jackpot.pretty.ImportAnalysis.neededImports
(ImportAnalysis.java:81)
	at org.netbeans.jackpot.save.Commit.commit(Commit.java:316)
	at org.netbeans.jackpot.builder.DefaultEnvironment.toSource
(DefaultEnvironment.java:120)
	at org.netbeans.jackpot.transform.TransformResult.toSource
(TransformResult.java:74)
	at org.netbeans.jackpot.transform.TransformResult.makeSelection
(TransformResult.java:57)
	at 
org.netbeans.jackpot.transform.TransformResult$TransformerResultImpl.getElement
(TransformResult.java:88)
	at org.netbeans.modules.jackpot.ModuleContext.checkSourceFiles
(ModuleContext.java:128)
	at org.netbeans.modules.jackpot.ModuleContext.acceptResults
(ModuleContext.java:120)
	at org.netbeans.jackpot.transform.Transformer.show(Transformer.java:87)
	at org.netbeans.jackpot.query.Query.apply(Query.java:74)
	at org.netbeans.jackpot.builder.Engine.runCommand(Engine.java:110)
	... 3 more
Comment 1 _ tball 2006-03-14 20:40:48 UTC
Fix committed yesterday, should be in March 14 daily build.  The problem was
that javac doesn't attribute fields in import statements (only packages and
classes); jackpot is now updated to handle that case.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo