Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 73082 - Mac OS X, switching between insert and overwrite mode
Mac OS X, switching between insert and overwrite mode
Status: VERIFIED WONTFIX
Product: editor
Classification: Unclassified
Component: Key bindings
5.x
Macintosh Mac OS X
: P3 (vote)
: 6.x
Assigned To: Max Sauer
issues@editor
:
: 129644 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-28 06:32 UTC by cbodner
Modified: 2010-10-12 13:37 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description cbodner 2006-02-28 06:32:47 UTC
Switching the NetBeans IDE editor from insert to overwrite mode is usually done
through pressing the <Ins> key. On the Mac keyboard, this key is labeled <help>
and a question mark appears as a mouse pointer instead of switching to overwrite
mode. How can we switch to overwrite mode on Mac OS X?
Comment 1 Peter Pis 2006-02-28 09:40:41 UTC
Reassigning to "editor" for evaluation.
Comment 2 Vitezslav Stejskal 2006-12-18 05:00:16 UTC
So, how do you normally toggle typing mode on Mac? What key do the other apps use?
Comment 3 Jiri Prox 2008-02-21 11:28:42 UTC
Waiting for feedback from mac-users

As I can see in http://docs.info.apple.com/article.html?artnum=75459, there is no default shortcut
Comment 4 Jiri Prox 2008-03-10 12:35:30 UTC
*** Issue 129644 has been marked as a duplicate of this issue. ***
Comment 5 Jiri Prox 2008-03-10 12:36:53 UTC
In duplicate issue there is proposal for shortcut + justification
Comment 6 Max Sauer 2008-03-11 13:26:43 UTC
The link in the duplicate issue refers to mapping of help>insert while using Parallels on Mac OS to imitate windows (BootCamp documentation). I've tried 
other apps, and none of them provides insert mode (it looks like there is no such thing on mac) -- some of them (MS Word,..) invoke help, other (TextEdit, 
..) provide just '?' (question mark) just like NB.

The other thing is that java does not provide any key event for the help key -- so i don't see any way how to map it to help (F1 on other platforms), as this 
seem to be a custom. 
Comment 7 Petr Dvorak 2008-03-11 13:36:52 UTC
Maybe this would be an issue for a java then? If you have a java port for Mac, it should provide a key event for all the
keys on the Mac keyboard...

If you do not get any key event for the Help key, there is nothing that can be done at the moment. Verified.
Comment 8 Max Sauer 2008-03-11 13:58:27 UTC
Yes -- but afaik apple bug DB is not open to search. You can file here: http://developer.apple.com/bugreporter/
But I've never done that ;) 
Comment 9 Jaromir Uhrik 2010-10-12 13:37:29 UTC
I use workaround for this issue - I have redefined Toggle Typing Mode in Keymap panel of NetBeans|Preferences...


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo