Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 72425 - cursor in editor looses focus under os x
cursor in editor looses focus under os x
Status: RESOLVED DUPLICATE of bug 60235
Product: platform
Classification: Unclassified
Component: Window System
5.x
Macintosh Mac OS X
: P3 (vote)
: 6.x
Assigned To: Milos Kleint
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-08 17:14 UTC by wgercken
Modified: 2008-12-22 16:06 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description wgercken 2006-02-08 17:14:02 UTC
Using the new release 5.0 on a Powerbook running OS 10.4 the editor eventually
looses the cursor. Clicking on text in the window places a highlight but does
not  position the cursor, which appears to be nowhere in site. The cursor
location appears in the status area (line number, position) but moving the
cursor with the arrow keys does not move the position. Further typing in the
window does not appear. Tabbing between source panes does not help. The only way
to resolve it is to exit and restart netbeans.
Comment 1 wgercken 2006-02-09 17:53:28 UTC
I was able to get the problem to repeat. It appears to be related to the editor
selection menu on the top right side of the IDE. When I expand the menu to look
for the name of an open source editor the menu appears normal. When I move the
mouse down the list of the available panes the area of the file name is erased.
This continues until I can clear the entire menu by scrolling over it. 
If I select a file name (for a tab) the cursor disapears as per my original
description.
Comment 2 wgercken 2006-02-09 20:44:02 UTC
The work around for this is to simply choose the same item (file name) from the
menu and click in the window. The cursor magically reappears.
Comment 3 Miloslav Metelka 2006-02-23 10:56:59 UTC
Reassigning to core/winsys for evaluation.
Comment 4 David Simonek 2006-02-23 11:39:55 UTC
Passing to Milos.
Comment 5 Milos Kleint 2006-02-23 12:08:38 UTC
this seems to be a duplicate of #60235. what exact version of 1.5 jdk are you using?
It's most probably an issue with the apple's 1.5 jdk. Please make sure you have
at least 1.5 release3, or preferrably 1.5 release4 developer preview (that's
accesible to registered memebers of thr apple developer network.)
Comment 6 Milos Kleint 2006-03-27 08:04:50 UTC
no response from the reported. marking as duplicate of #60235

*** This issue has been marked as a duplicate of 60235 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo