Bug 70747 - Layer error
Layer error
Status: RESOLVED FIXED
Product: contrib
Classification: Unclassified
Component: Jackpot
5.x
All All
: P1 (vote)
: TBD
Assigned To: issues@contrib
issues@contrib
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-22 19:01 UTC by Jesse Glick
Modified: 2005-12-23 00:37 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2005-12-22 19:01:35 UTC
I updated to

org.netbeans.modules.jackpot.rules [1.1.8 051221]

and got

[org.netbeans.core.projects] *********** Exception occurred ************ at 1:57
PM on Dec 22, 2005
java.io.IOException:
jar:file:/home/jglick/nbdev/modules/org-netbeans-modules-jackpot-rules.jar!/org/netbeans/modules/jackpot/rules/layer.xml:
org.xml.sax.SAXParseException: The element type "file" must be terminated by the
matching end-tag "</file>".
	at org.openide.filesystems.XMLFileSystem.setXmlUrls(XMLFileSystem.java:300)
	at org.openide.filesystems.XMLFileSystem.setXmlUrls(XMLFileSystem.java:236)
	at org.netbeans.core.startup.layers.NonCacheManager.store(NonCacheManager.java:57)
[catch] at
org.netbeans.core.startup.layers.ModuleLayeredFileSystem$1.run(ModuleLayeredFileSystem.java:266)
	at org.openide.filesystems.EventControl.runAtomicAction(EventControl.java:96)
	at org.openide.filesystems.FileSystem.runAtomicAction(FileSystem.java:450)
	at
org.netbeans.core.startup.layers.ModuleLayeredFileSystem.setURLs(ModuleLayeredFileSystem.java:241)
	at
org.netbeans.core.startup.layers.ModuleLayeredFileSystem.addURLs(ModuleLayeredFileSystem.java:314)
	at org.netbeans.core.startup.NbInstaller.loadLayers(NbInstaller.java:548)
	at org.netbeans.core.startup.NbInstaller.load(NbInstaller.java:237)
	at org.netbeans.ModuleManager.enable(ModuleManager.java:898)
	at org.netbeans.core.startup.ModuleList.installNew(ModuleList.java:377)
	at org.netbeans.core.startup.ModuleList.trigger(ModuleList.java:311)
	at org.netbeans.core.startup.ModuleSystem.restore(ModuleSystem.java:244)
	at org.netbeans.core.startup.Main.getModuleSystem(Main.java:206)
	at org.netbeans.core.startup.Main.start(Main.java:377)
	at org.netbeans.core.startup.TopThreadGroup.run(TopThreadGroup.java:90)
	at java.lang.Thread.run(Thread.java:626)
Caused by: org.xml.sax.SAXParseException: The element type "file" must be
terminated by the matching end-tag "</file>".
	at
com.sun.org.apache.xerces.internal.util.ErrorHandlerWrapper.createSAXParseException(ErrorHandlerWrapper.java:195)
	at
com.sun.org.apache.xerces.internal.util.ErrorHandlerWrapper.fatalError(ErrorHandlerWrapper.java:174)
	at
com.sun.org.apache.xerces.internal.impl.XMLErrorReporter.reportError(XMLErrorReporter.java:388)
	at
com.sun.org.apache.xerces.internal.impl.XMLScanner.reportFatalError(XMLScanner.java:1401)
	at
com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanEndElement(XMLDocumentFragmentScannerImpl.java:1734)
	at
com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl$FragmentContentDriver.next(XMLDocumentFragmentScannerImpl.java:2918)
	at
com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl.next(XMLDocumentScannerImpl.java:645)
	at
com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanDocument(XMLDocumentFragmentScannerImpl.java:506)
	at
com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:807)
	at
com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:737)
	at com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(XMLParser.java:107)
	at
com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(AbstractSAXParser.java:1132)
	at
com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl$JAXPSAXParser.parse(SAXParserImpl.java:533)
	at org.openide.filesystems.XMLFileSystem.setXmlUrls(XMLFileSystem.java:292)
	... 17 more

The cause is clear:

        <folder name="Help">
            <folder name="Tutorials">
                <file name="j2ee-tutorial.url"
url="nbresloc:/org/netbeans/modules/j2ee/platform/j2ee-tut.url">
        </folder>

(What is this doing here anyway??)
Comment 1 _ tball 2005-12-23 00:37:03 UTC
Fixed error, and updated auto update center.  My apologies for this mistake.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo