Bug 69846 - Display database-specific data types in the column properties
Display database-specific data types in the column properties
Status: RESOLVED FIXED
Product: db
Classification: Unclassified
Component: Code
5.x
All All
: P1 with 1 vote (vote)
: 7.4
Assigned To: Jiri Rechtacek
issues@db
: API_REVIEW_FAST, NETFIX, PATCH_AVAILABLE
: 175747 (view as bug list)
Depends on:
Blocks: 152818 163595
  Show dependency treegraph
 
Reported: 2005-12-04 16:19 UTC by Andrei Badea
Modified: 2013-05-31 01:23 UTC (History)
2 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments
proposed patch part1 v1 (7.82 KB, patch)
2013-05-09 11:27 UTC, matthias42
Details | Diff
proposed patch part2 v1 (5.57 KB, patch)
2013-05-09 11:28 UTC, matthias42
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Andrei Badea 2005-12-04 16:19:24 UTC
The Database Explorer currently displays types from java.sql.Types as the colum
data type in the column properties. The column database-specific data type
should also be displayed.

Some databases map multiple database-specific data types to a single type from
java.sql.Types or map them to java.sql.Types.OTHER (see issue 69243 for an
example). Therefore it's not possible currently to tell the column type just by
looking at the node's properties.
Comment 1 David Vancouvering 2007-05-29 21:34:29 UTC
Isn't this the same as 63708?
Comment 2 David Vancouvering 2007-05-29 21:35:51 UTC
Ignore my question, this is not the same.
Comment 3 Jiri Rechtacek 2009-10-16 14:11:40 UTC
Reassigned to new owner.
Comment 4 PrplHaz4 2013-03-11 20:16:03 UTC
This proved extremely frustrating for me in using MySQL "DateTime" column type.  NetBeans was reporting it as type "TimeStamp", which also exists in MySQL, but does not function the same.

I beleive it should be default for the database explorer/database services to report the correct db-centric column types as the Java type is irrelevant when you're not developing in Java.
Comment 5 matthias42 2013-05-09 11:24:56 UTC
*** Bug 175747 has been marked as a duplicate of this bug. ***
Comment 6 matthias42 2013-05-09 11:27:27 UTC
Created attachment 134252 [details]
proposed patch part1  v1
Comment 7 matthias42 2013-05-09 11:28:00 UTC
Created attachment 134253 [details]
proposed patch part2  v1
Comment 8 Jaroslav Havlin 2013-05-20 17:06:10 UTC
Thank you very much, Matthias, patches work just fine.
Comment 9 Jaroslav Havlin 2013-05-20 17:10:07 UTC
Please review API changes in friend-private module db.metadata.model.

New methods:
org.netbeans.modules.db.metadata.model.api.Value.getTypeName()
org.netbeans.modules.db.metadata.model.spi.ValueImplementation.getTypeName()

Thank you.
Comment 10 Jaroslav Havlin 2013-05-28 14:44:47 UTC
If there are no objections, I'll integrate the patch tomorrow.
Thank you for reviewing.
Comment 11 Jaroslav Havlin 2013-05-29 14:58:09 UTC
Integrated as http://hg.netbeans.org/core-main/rev/67430df76120
Thank you again, Matthias.
Comment 12 Quality Engineering 2013-05-31 01:23:15 UTC
Integrated into 'main-golden', will be available in build *201305302301* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/67430df76120
User: Jaroslav Havlin <jhavlin@netbeans.org>
Log: #69846: Display database-specific data types in the column properties

Patch by Matthias42.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo