Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 69078 - build-jnlp fails for Utilities & HTML editor
build-jnlp fails for Utilities & HTML editor
Status: VERIFIED FIXED
Product: apisupport
Classification: Unclassified
Component: Harness
5.x
PC Windows XP
: P2 (vote)
: 5.x
Assigned To: Jaroslav Tulach
issues@apisupport
:
Depends on: 57611
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-22 08:52 UTC by gaucho72
Modified: 2005-12-22 09:54 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Output for build-jnlp (3.34 KB, text/plain)
2005-11-22 08:53 UTC, gaucho72
Details
The changes in build scripts to apply (3.92 KB, patch)
2005-12-14 14:35 UTC, Jaroslav Tulach
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description gaucho72 2005-11-22 08:52:30 UTC
1. Create new module suite project.
2. Include the whole cluster platform6 and from ide6 the modules:
   - User Utilities [org.netbeans.modules.utilities] and therefore also
   - Experimetal Search API [org.openidex.util]
3. Build JNLP-Application and it fails.

You'll find attached the output for the build.
Comment 1 gaucho72 2005-11-22 08:53:42 UTC
Created attachment 27124 [details]
Output for build-jnlp
Comment 2 Jesse Glick 2005-12-05 19:15:08 UTC
Yarda is it intentional that CLI-containing modules are rejected? Seems to me
that it should be enough to either add the CLI JAR(s) to the classpath, or
simply ignore them for purposes of this error message - probably would never be
used at runtime anyway.
Comment 3 Jaroslav Tulach 2005-12-07 17:52:56 UTC
I think I will not fix this for 5.0. I'd like to integrate better CLI api  
(issue 57611) and then there will be no need for core/cli.jars Ok? 
 
Comment 4 Jesse Glick 2005-12-07 20:37:01 UTC
P3 seems more appropriate.
Comment 5 Jaroslav Tulach 2005-12-14 14:20:31 UTC
 
 
"#69078: Enriching the amount of modules that are JNLP buildable to include 
'User Utilities' as well as 'HTML Editor'" 
Checking in apisupport/harness/release/jnlp.xml; 
/cvs/apisupport/harness/release/jnlp.xml,v  <--  jnlp.xml 
new revision: 1.15.2.4; previous revision: 1.15.2.3 
done 
Checking in html/editor/nbproject/project.properties; 
/cvs/html/editor/nbproject/project.properties,v  <--  project.properties 
new revision: 1.6; previous revision: 1.5 
done 
Checking in nbbuild/build.properties; 
/cvs/nbbuild/build.properties,v  <--  build.properties 
new revision: 1.354; previous revision: 1.353 
done 
Checking in nbbuild/build.xml; 
/cvs/nbbuild/build.xml,v  <--  build.xml 
new revision: 1.720; previous revision: 1.719 
done 
Checking in usersguide/nbproject/project.properties; 
/cvs/usersguide/nbproject/project.properties,v  <--  project.properties 
new revision: 1.4; previous revision: 1.3 
done 
Checking in utilities/nbproject/project.properties; 
/cvs/utilities/nbproject/project.properties,v  <--  project.properties 
new revision: 1.10; previous revision: 1.9 
 
Comment 6 Jaroslav Tulach 2005-12-14 14:25:39 UTC
"#69078: Additional merge into trunk + I've reverted the commit to  1.15.2.4" 
/cvs/apisupport/harness/release/jnlp.xml,v  <--  jnlp.xml  
new revision: 1.25; previous revision: 1.24  
  
Comment 7 Jaroslav Tulach 2005-12-14 14:35:48 UTC
Created attachment 27847 [details]
The changes in build scripts to apply
Comment 8 Jesse Glick 2005-12-14 15:19:28 UTC
Looks OK but I would like some explanation of what the effect of the new
config.modules.jnlp will be. When org.jdesktop.layout was put into platform I
had to add docs/swing-layout-1.0-doc.zip to verifyexcludes in jnlp.xml; I also
added it to jnlp.verify.excludes in the libs/swing-layout module, but that had
no apparent effect (jnlp-build on a platform app still failed on this module
until I patched jnlp.xml). There seems to be a duplication of the list of files
to ignore for JNLP: jnlp.xml, which does something, and **/project.properties,
which AFAICT do nothing. Is this documented somewhere?
Comment 9 pzajac 2005-12-14 16:36:20 UTC
It looks also fine for me.  WHY TM is 5.1M  wheb this bug contais 50_HR_FIX? 

Comment 10 Jesse Glick 2005-12-14 17:39:44 UTC
To pzajac: it is fixed in the trunk (hence 5.1 M1) but eligible for 5.0 (hence
50_HR_FIX).
Comment 11 Jaroslav Tulach 2005-12-15 07:12:23 UTC
Yesterday, when I was working on a fix I had different experience than Jesse.    
Here are the steps I did:    
    
#1 - I realized that the amount of JNLPizable modules does not equal platform    
cluster, so I introduced one new property in nbbuild/*.properties to list some    
more. people complained about utilities & html editor, so I found a reasonable    
set that included them    
    
#2 - I invoked ant -f nbbuild/build.xml build-jnlp as many times, as I got    
failures, and everytime I fixed <module>/nbproject/project.properties to    
contain the right exclude    
    
#3 - I took the all the excludes and added them into jnlp.xml (this one is    
used when building from binaries) and verified that all the modules I had to    
modify nbproject/project.properties for, are now buildable from binaries    
    
That is why I think it, all changes in *properties, *xml are necessary and (to    
level I could verify) they seem to be in sync. I am not sure if this is  
extensively documented. If you tell me where to put it, I can do it. Or better 
file me an issue and I write a task that will concatenate all excludes from 
all modules in the config and put them into harness/jnlp.xml during build time 
(not for 5.0). 
Comment 12 Jesse Glick 2005-12-15 17:22:37 UTC
Filed issue #70477 for last point.
Comment 13 Jaroslav Tulach 2005-12-16 16:25:51 UTC
"#69078: build-jnlp fails for Utilities & HTML editor" 
 
 
Checking in apisupport/harness/release/jnlp.xml; 
/cvs/apisupport/harness/release/jnlp.xml,v  <--  jnlp.xml 
new revision: 1.24.2.1; previous revision: 1.24 
done 
Checking in html/editor/nbproject/project.properties; 
/cvs/html/editor/nbproject/project.properties,v  <--  project.properties 
new revision: 1.5.8.1; previous revision: 1.5 
done 
Checking in nbbuild/build.properties; 
/cvs/nbbuild/build.properties,v  <--  build.properties 
new revision: 1.351.2.2; previous revision: 1.351.2.1 
done 
Checking in nbbuild/build.xml; 
/cvs/nbbuild/build.xml,v  <--  build.xml 
new revision: 1.719.2.2; previous revision: 1.719.2.1 
done 
Checking in usersguide/nbproject/project.properties; 
/cvs/usersguide/nbproject/project.properties,v  <--  project.properties 
new revision: 1.3.28.1; previous revision: 1.3 
done 
Checking in utilities/nbproject/project.properties; 
/cvs/utilities/nbproject/project.properties,v  <--  project.properties 
new revision: 1.9.24.1; previous revision: 1.9 
 
Comment 14 Tomas Danek 2005-12-22 09:33:15 UTC
unreprodubible in 5.0 20051221 => verified.
Comment 15 Tomas Danek 2005-12-22 09:54:53 UTC
..and unreproducible=>verified also in trunk.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo