Bug 68688 - "Building Jackpot Space" dialog sometimes does not disappear
"Building Jackpot Space" dialog sometimes does not disappear
Status: RESOLVED FIXED
Product: contrib
Classification: Unclassified
Component: Jackpot
5.x
All All
: P3 (vote)
: TBD
Assigned To: _ tball
issues@contrib
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-14 20:37 UTC by Jesse Glick
Modified: 2006-03-09 18:30 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2005-11-14 20:37:39 UTC
Sometimes - but not always - after starting a new Jackpot session, the progress
dialog does not disappear after it is finished. It is nonmodal so I can continue
work, but I need to push the dead dialog offscreen to get it out of the way.
Comment 1 Jesse Glick 2005-11-14 20:38:09 UTC
051111, b60,

	org.netbeans.jackpot [1.1.7 051112]
	org.netbeans.modules.jackpot/1 [1.1.7 051112 @BUILD_NUMBER_SUBST@]
	org.netbeans.modules.jackpot.rules [1.1.4 051112]
Comment 2 Jesse Glick 2005-11-14 20:39:14 UTC
BTW - close button on the dialogs does nothing. Have to restart IDE to clean up.
Comment 3 _ tball 2005-11-17 05:59:31 UTC
Added dispose() method to BuildMonitor interface, builder uses a try/finally
block to ensure it gets called regardless of any build exceptions.
Comment 4 Jesse Glick 2005-12-02 20:25:38 UTC
I'm not sure this is fixed as I think I saw it again using an updated NBM:

org.netbeans.modules.jackpot/1 [1.1.11 051122]
Comment 5 _ tball 2005-12-12 23:33:04 UTC
Found a system that reproduced this problem.  It turns out that on some systems
Dialog.setVisible(false) is not sufficient to get rid of a dialog -- you have to
explicitly call Dialog.dispose(), which the jackpot module now does.
Comment 6 Jesse Glick 2006-01-17 20:11:10 UTC
Just failed for me again, using latest Mustang on Linux and

org.netbeans.modules.jackpot/1 [1.1.17 060113]

Note

Jan 17, 2006 3:05:38 PM org.netbeans.modules.jackpot.BuildMonitor buildStarted
INFO: begin compile
Jan 17, 2006 3:05:39 PM org.netbeans.modules.jackpot.BuildMonitor
setTotalSourceFiles
INFO: Parsing 1,403 source files
Jan 17, 2006 3:06:23 PM org.netbeans.modules.jackpot.BuildMonitor buildFinished
INFO: total compile time=25.828 seconds
Jan 17, 2006 3:06:23 PM org.netbeans.modules.jackpot.BuildMonitor buildFinished
INFO: 61 errors, 0 warnings

and OK-looking output in Jackpot Log.
Comment 7 Jesse Glick 2006-01-17 20:12:26 UTC
BTW from a UI perspective I would anyway recommend getting rid of the dialog and
just using ProgressHandle. Or at least add a Cancel button to the dialog.
Comment 8 Jesse Glick 2006-01-17 20:16:54 UTC
*Might* have been a symptom of an out-of-memory condition, but I did not see any
dialog about it if so.
Comment 9 Jan Lahoda 2006-02-14 16:24:16 UTC
Tom, could you please try to add:
try {
    Thread.sleep(50);
} catch (InterruptedException e) {}
right before
Dialog.setVisibility(false);
(into the AWT Event Thread)? It might help.
Comment 10 Jan Lahoda 2006-02-14 22:59:59 UTC
I think I should add some explanation: there is a JDK bug which causes behaviour
very similar to the described behaviour. The Thread.sleep(50) is a workaround to
it. Please see issue #54585 for more information.
Comment 11 _ tball 2006-03-09 18:30:15 UTC
I switched the progress dialog to the IDE's progress status widget (which Jesse
preferred anyway).  So because I am no longer opening a progress dialog anymore,
I think it's safe to really close it again.  BTW, the try/finally logic for
clearing the dialog is still there.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo