Bug 67106 - Cannot always edit Commit Message
Cannot always edit Commit Message
Status: RESOLVED FIXED
Product: versioncontrol
Classification: Unclassified
Component: CVS
5.x
PC Linux
: P4 (vote)
: 6.x
Assigned To: issues@versioncontrol
issues@versioncontrol
: FOCUS
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-19 11:02 UTC by _ rkusterer
Modified: 2007-01-04 17:14 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description _ rkusterer 2005-10-19 11:02:41 UTC
In the new NB 5 beta cvs, sometimes I cannot edit the commit message at all.
(Committing itself works perfectly, just the commit message is the problem.)

With "cannot edit" I mean: 
The commit dialog comes up with the previous message (that's OK), and the string
is selected (OK), but when I type the new message or hit backspace, the old
message remains highlighted and nothing changes.

With "sometimes" I mean:
- When I choose CVS>Commit from the IDE's main menu, editing the commit message
is possible _every time_.
- But when I choose Commit from a right-click contextual menu (within the Editor
by clicking the files tab, or within Files/Favorites/Projects/Versioning View
etc), the message is editable in circa two-thirds of the cases. In circa one
third of the cases, the commit message remains uneditable, even if I cancel and
try committing the same file again. In those cases, I need to choose Commit from
the main menu if I ever want to edit the message before commiting.

I'm sorry I don't know how to reproduce it on purpose, I don't see any pattern.
What could be the difference between calling the same command from the Main Menu
and from the context menu? It's far from being a showstopper, just annoying if I
can't rely on the handy context-menu.
Comment 1 _ pkuzel 2005-10-19 12:57:34 UTC
Looks like pure Swing issue. There is no setEnabled(), etc. Main menu and popup
menu actions are identical.

JDK version?
Comment 2 _ rkusterer 2005-10-19 15:34:03 UTC
[rik:~]> java -version
java version "1.5.0_04"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_04-b05)
Java HotSpot(TM) Client VM (build 1.5.0_04-b05, mixed mode, sharing)
[rik:~]> 
Comment 3 _ rkusterer 2005-10-19 15:34:19 UTC
> java -version
java version "1.5.0_04"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_04-b05)
Java HotSpot(TM) Client VM (build 1.5.0_04-b05, mixed mode, sharing)
Comment 4 _ pkuzel 2005-12-14 09:45:25 UTC
Just happened to me. Looks like broken internal Swing keyboard focus logic
(changing focus with mouse works).

Checking in CommitSettings.java;
/shared/data/ccvs/repository/javacvs/cvsmodule/src/org/netbeans/modules/versioning/system/cvss/ui/actions/commit/CommitSettings.java,v
 <--  CommitSettings.java
new revision: 1.9; previous revision: 1.8
done


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo