Bug 66777 - Documents.. action (Shift-F4) shows node names
Documents.. action (Shift-F4) shows node names
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Window System
5.x
All All
: P2 (vote)
: 5.x
Assigned To: David Simonek
issues@platform
: API, API_REVIEW_FAST, REGRESSION
: 67514 67683 67692 (view as bug list)
Depends on:
Blocks: 66963
  Show dependency treegraph
 
Reported: 2005-10-14 10:05 UTC by _ rkubacki
Modified: 2008-12-22 15:59 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
diff of proposed solution (12.34 KB, patch)
2005-10-21 12:41 UTC, David Simonek
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description _ rkubacki 2005-10-14 10:05:21 UTC
dev build from Oct 13, JDK 1.5.0

Open documents dialog when a cursor is inside a method of some Java file. The
name of method is displayed instead of file name in the list
Comment 1 David Simonek 2005-10-21 12:38:06 UTC
I dediced to try to fix this bug with heavy artillery, API change which adds
methods TopComponent.getHtmlDisplayName/setHtmlDisplayName. This would allow fix
several problems:

1) this issue
2) issue 66963 (asterisk in names)
3) not filed problem that quick search in documents dialog doesn't work on
htmlized names (cvs colored)
4) will open the possibility to fix related bugs in tab control (bad display
size of tabs etc) 


 
Comment 2 David Simonek 2005-10-21 12:41:30 UTC
Created attachment 26213 [details]
diff of proposed solution
Comment 3 David Simonek 2005-10-21 12:46:05 UTC
Forgot to say that also CloneableEditorSupport.messageHtmlName has to be added.
Otherwise API change is relatively easy and impl is straighforward. Passing to
fast track devrev process.

One more note - I *could* solve original problem by stripping html tags from the
name, but API is much nicer and leads to cleaner code, which also performs better.
Comment 4 Miloslav Metelka 2005-10-26 09:36:39 UTC
*** Issue 67514 has been marked as a duplicate of this issue. ***
Comment 5 David Simonek 2005-10-27 15:52:30 UTC
*** Issue 67683 has been marked as a duplicate of this issue. ***
Comment 6 David Simonek 2005-10-31 15:25:47 UTC
No complaints for a week, so I'm taking this issue back and going to integrate
soon, after I fullfill usual "paperwork" of apichanges etc. 
Comment 7 David Simonek 2005-10-31 17:07:31 UTC
fixed in main trunk:

Checking in core/windows/src/org/netbeans/core/windows/WindowManagerImpl.java;
/cvs/core/windows/src/org/netbeans/core/windows/WindowManagerImpl.java,v  <-- 
WindowManagerImpl.java
new revision: 1.35; previous revision: 1.34
done
Checking in openide/text/manifest.mf;
/cvs/openide/text/manifest.mf,v  <--  manifest.mf
new revision: 1.10; previous revision: 1.9
done
Checking in openide/text/apichanges.xml;
/cvs/openide/text/apichanges.xml,v  <--  apichanges.xml
new revision: 1.11; previous revision: 1.10
done
Checking in openide/text/src/org/openide/text/CloneableEditorSupport.java;
/cvs/openide/text/src/org/openide/text/CloneableEditorSupport.java,v  <-- 
CloneableEditorSupport.java
new revision: 1.13; previous revision: 1.12
done
Checking in openide/text/src/org/openide/text/CloneableEditor.java;
/cvs/openide/text/src/org/openide/text/CloneableEditor.java,v  <-- 
CloneableEditor.java
new revision: 1.7; previous revision: 1.6
done
Checking in openide/windows/src/org/openide/windows/TopComponent.java;
/cvs/openide/windows/src/org/openide/windows/TopComponent.java,v  <-- 
TopComponent.java
new revision: 1.5; previous revision: 1.4
done
Checking in openide/windows/src/org/openide/windows/DummyWindowManager.java;
/cvs/openide/windows/src/org/openide/windows/DummyWindowManager.java,v  <-- 
DummyWindowManager.java
new revision: 1.2; previous revision: 1.1
done
Checking in openide/windows/src/org/openide/windows/WindowManager.java;
/cvs/openide/windows/src/org/openide/windows/WindowManager.java,v  <-- 
WindowManager.java
new revision: 1.3; previous revision: 1.2
done
Checking in openide/windows/manifest.mf;
/cvs/openide/windows/manifest.mf,v  <--  manifest.mf
new revision: 1.5; previous revision: 1.4
done
Checking in openide/windows/apichanges.xml;
/cvs/openide/windows/apichanges.xml,v  <--  apichanges.xml
new revision: 1.3; previous revision: 1.2
done
Checking in core/windows/src/org/netbeans/core/windows/view/ui/DocumentsDlg.java;
/cvs/core/windows/src/org/netbeans/core/windows/view/ui/DocumentsDlg.java,v  <--
 DocumentsDlg.java
new revision: 1.18; previous revision: 1.17
done
Checking in openide/loaders/src/org/openide/text/DataEditorSupport.java;
/cvs/openide/loaders/src/org/openide/text/DataEditorSupport.java,v  <-- 
DataEditorSupport.java
new revision: 1.29; previous revision: 1.28
Comment 8 Marian Mirilovic 2005-11-01 14:38:41 UTC
*** Issue 67692 has been marked as a duplicate of this issue. ***
Comment 9 Marian Mirilovic 2005-11-04 15:18:42 UTC
verified in NB5.0(200511031900)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo