Bug 66126 - ability to run tests without building netbeans
ability to run tests without building netbeans
Status: VERIFIED DUPLICATE of bug 61014
Product: apisupport
Classification: Unclassified
Component: Harness
5.x
All All
: P3 (vote)
: 5.x
Assigned To: Jaroslav Tulach
issues@apisupport
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-06 13:29 UTC by pzajac
Modified: 2006-02-14 17:57 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pzajac 2005-10-06 13:29:25 UTC
I want to run apisupport on our testing infrastructucture. To do this it is
necessary remove dependency on nbbuild/netbeans 

Exact steps how I want to run the tests for apissuport
cvs co standard_nowww xtest_nowww
ant -f nbbuild/build.xml all-xtest
ant -f apissupport/test/build.xml -Dnetbeans.dest.dir="unzipped netbeans folder"

I hope that it is everything what we need to do. 

the dependency to ${nb_all}/nbbuild/netbeans

should be replace by 
${netbeans.dest.dir}
Comment 1 Jesse Glick 2005-10-07 22:22:29 UTC
Not possible to run apisupport tests on test4u infrastructure without major
refactoring of the tests and a lot of added code. Many tests use nb.org project
sources as test cases; these would all have to be rewritten. It is not enough to
subst ${netbeans.dest.dir} for nbbuild/netbeans because nb.org modules use
nbbuild/netbeans as their dest dir and this is not overridable as far as
apisupport is concerned.

*** This issue has been marked as a duplicate of 61014 ***
Comment 2 pzajac 2005-11-01 13:52:00 UTC
v


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo