Bug 64677 - [JNLP] wrong code base name in jnlp descriptor
[JNLP] wrong code base name in jnlp descriptor
Status: VERIFIED FIXED
Product: apisupport
Classification: Unclassified
Component: Harness
5.x
All All
: P1 (vote)
: 5.x
Assigned To: Jaroslav Tulach
issues@apisupport
5.0-beta-stopper
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-19 16:13 UTC by pzajac
Modified: 2005-09-23 10:18 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pzajac 2005-09-19 16:13:46 UTC
[200509181800]
Steps to reproduce:
1) Create Feed Reader project from sample templates
2) Perform Jnlp build action on to Feed Reader Application module suite

Look into generated war file. The jnlp files in app folder contain this codebase
on my machine :

codebase='file:/usr/local/pzajac/tmp/feedreader-suite-4/build/jnlp/app'
Comment 1 Jaroslav Tulach 2005-09-20 12:15:43 UTC
Fix is likely simple, however I am going to try to write a test. That can take 
a while. 
Comment 2 Jaroslav Tulach 2005-09-22 07:04:11 UTC
"#64677: Ensuring no local URL is present in the final war file" 
 
 
Checking in nbbuild/templates/common.xml; 
/cvs/nbbuild/templates/common.xml,v  <--  common.xml 
new revision: 1.18; previous revision: 1.17 
done 
Checking in apisupport/harness/release/jnlp.xml; 
/cvs/apisupport/harness/release/jnlp.xml,v  <--  jnlp.xml 
new revision: 1.17; previous revision: 1.16 
done 
Checking in apisupport/project/nbproject/project.properties; 
/cvs/apisupport/project/nbproject/project.properties,v  <--  
project.properties 
new revision: 1.17; previous revision: 1.16 
done 
Checking in 
apisupport/project/test/unit/src/org/netbeans/modules/apisupport/project/DialogDisplayerImpl.java; 
/cvs/apisupport/project/test/unit/src/org/netbeans/modules/apisupport/project/DialogDisplayerImpl.java,v  
<--  DialogDisplayerImpl.java 
new revision: 1.2; previous revision: 1.1 
done 
Checking in 
apisupport/project/test/unit/src/org/netbeans/modules/apisupport/project/jnlp/GenerateJNLPApplicationTest.java; 
/cvs/apisupport/project/test/unit/src/org/netbeans/modules/apisupport/project/jnlp/GenerateJNLPApplicationTest.java,v  
<--  GenerateJNLPApplicationTest.java 
new revision: 1.2; previous revision: 1.1 
 
Comment 3 pzajac 2005-09-23 09:34:35 UTC
after talk with Jarda we decided to commit the fix to beta branch. Because it
should be quit bit impact for users who wants to test his JNLP build on app server. 

verified in trunk
Comment 4 Jaroslav Tulach 2005-09-23 10:18:04 UTC
"Merge of 64677 to 5.0 beta" 
 
 
Checking in harness/release/jnlp.xml; 
/cvs/apisupport/harness/release/jnlp.xml,v  <--  jnlp.xml 
new revision: 1.15.2.1; previous revision: 1.15 
 


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo