Bug 6465 - Code destruction during renaming class in Explorer.
Code destruction during renaming class in Explorer.
Status: CLOSED WORKSFORME
Product: platform
Classification: Unclassified
Component: -- Other --
3.x
All All
: P1 (vote)
: TBD
Assigned To: Svata Dedic
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2000-04-27 22:06 UTC by Jan Becicka
Modified: 2008-12-23 11:52 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Becicka 2000-04-27 22:06:10 UTC
1. Create Class using new from template
2. Add method(s)
3. Using Explorer Change name of .java file, which includes this class
4. Method(s) from 2. is(are) out!!!! No undo !!!!. I thing, that Forte reloads last saved source. If you don`t see any loss of code, try do step 3 once more.
5. Class is not renamed -> bug 6412

Note:
VERY hard to reproduce.

[Svata] Additional info:
Following the above steps we were able to reproduce the reloading on Honza`s computer only. No other computer (even the same HW configuration) behaved that way. More, when I patched javaloader`s code
to show some debugging output, the problem didn`t occur.
I suspect some race condition, not necessarily inside the JavaLoader.
Comment 1 Quality Engineering 2003-07-02 16:49:35 UTC
Resolved for 3.4.x or earlier, no new info since then -> verify
Comment 2 Quality Engineering 2003-07-02 17:20:37 UTC
Resolved for 3.4.x or earlier, no new info since then -> closing.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo