Bug 63151 - NBM and suite projects should support move
NBM and suite projects should support move
Status: RESOLVED FIXED
Product: apisupport
Classification: Unclassified
Component: Project
5.x
All All
: P1 (vote)
: 5.x
Assigned To: Martin Krauskopf
issues@apisupport
:
: 61689 66081 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-26 11:21 UTC by Jesse Glick
Modified: 2006-01-12 04:57 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2005-08-26 11:21:15 UTC
In the case of suite component module projects, should additionally update the
suite's reference to the module, and update the module's reference to the suite.
Comment 1 Martin Krauskopf 2005-09-15 05:01:03 UTC
High priority feature for the next release.
Comment 2 Jesse Glick 2005-10-18 00:13:47 UTC
*** Issue 66081 has been marked as a duplicate of this issue. ***
Comment 3 Jesse Glick 2005-10-24 19:11:52 UTC
*** Issue 61689 has been marked as a duplicate of this issue. ***
Comment 4 Martin Krauskopf 2006-01-10 04:39:13 UTC
Move should not be problem. Rename is a little problematic in the case of
apisupport. cf. with dev@apisupport discussion. Filed a new issue 71214 for rename.
Comment 5 Martin Krauskopf 2006-01-11 17:01:38 UTC
Ups. Fixed few hours ago. I forgot to close this. Here is the commit:

http://apisupport.netbeans.org/servlets/ReadMsg?list=cvs&msgNo=3074
Comment 6 Martin Krauskopf 2006-01-11 17:19:54 UTC
BTW when suite is moved modules which are relative to its directory are not
moved. Not sure. Probably would be better if we detect which suite components
are in a suite's directory and move them as well, so user doesn't need to do so
for each suite-component. Suite components outside of suite shouldn't be
presuambly touched.
Comment 7 Jesse Glick 2006-01-11 23:37:37 UTC
"Probably would be better if we detect which suite components are in a suite's
directory and move them as well, so user doesn't need to do so for each
suite-component. Suite components outside of suite shouldn't be presuambly
touched." - agreed.
Comment 8 Martin Krauskopf 2006-01-12 04:57:00 UTC
Filed issue 71293.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo