Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 62946 - "Use System Proxy" ignores changes after app launch
"Use System Proxy" ignores changes after app launch
Status: RESOLVED DUPLICATE of bug 201731
Product: platform
Classification: Unclassified
Component: -- Other --
5.x
All All
: P3 (vote)
: 7.4
Assigned To: Libor Fischmeistr
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-24 14:09 UTC by Jesse Glick
Modified: 2013-04-04 10:34 UTC (History)
4 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2005-08-24 14:09:11 UTC
I would like to use "Use System Proxy". However "Use System Proxy" does not
generally work for me because it reads system proxy settings only when the IDE
is launched, and I often go on and off SWAN while the IDE is running. That is
why I generally prefer to explicitly control the proxy state in Options | System
Settings (formerly available also in the Setup Wizard). (Unfortunately this does
not seem to affect cvslite.)

Ideally under Gnome the IDE would consult "/usr/bin/gconftool-2 --get
/system/proxy/mode" every time it needed to know the proxy setting, but Java
does not support this for all usages (only has a system property, no callback).
Maybe we could use some trick like we use for the system clipboard and file
refreshes: when the main window gets focus, recheck the OS proxy settings and
possibly update the system property.

Won't work for Windows users however, since nbexec.exe uses native code to find
this info, but could at least be fixed for Gnome users.
Comment 1 Tomas Danek 2005-08-31 11:39:38 UTC
Isn't it conneted with issue 62798?
Comment 2 Jesse Glick 2005-08-31 16:41:07 UTC
I don't see any connection to issue #62798.
Comment 3 Jan Chalupa 2005-09-09 17:03:00 UTC
I'm not in favor of solutions that will work on some platforms under some
circumstances only. While this feature might be potentially implementable under
Gnome, there's currently no way to implement it on Windows (unless we want to
implement a JNI bridge that would repeatedly consult Windows registry) and other
platforms.

It would be a nice ENHANCEMENT, but I'm seriously thinking about closing it as
WONTFIX.
Comment 4 Marian Mirilovic 2006-10-23 09:17:17 UTC
Jirka this is yours, isn't it ?
Comment 5 _ rkubacki 2006-10-30 09:55:38 UTC
Is default ProxySelector in JDK capable to reflect proxy changes? I am afraid it
will have the same problem.
Comment 6 eppesuigoccas 2009-03-18 13:12:37 UTC
Is there any news about this  bug report?
How about checking for system proxy every time it is required instead of caching its value?
Comment 7 Libor Fischmeistr 2013-04-04 10:34:59 UTC

*** This bug has been marked as a duplicate of bug 201731 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo