Bug 61885 - Deadlock: ResourceImpl.applyDiff, CompletionImpl.insertUpdate, CompletionImpl$7.run
Deadlock: ResourceImpl.applyDiff, CompletionImpl.insertUpdate, CompletionImpl...
Status: RESOLVED DUPLICATE of bug 61827
Product: java
Classification: Unclassified
Component: Editor
5.x
All All
: P3 (vote)
: 5.x
Assigned To: issues@java
issues@java
: RANDOM, THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-05 23:14 UTC by Jesse Glick
Modified: 2005-09-05 10:01 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Thread dump (11.38 KB, text/plain)
2005-08-05 23:15 UTC, Jesse Glick
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2005-08-05 23:14:56 UTC
Occurred quite at random, no idea how to reproduce. Data loss.
Comment 1 Jesse Glick 2005-08-05 23:15:16 UTC
Created attachment 23536 [details]
Thread dump
Comment 2 Martin Matula 2005-08-18 11:24:46 UTC
Wrong ordering of document lock and CompletionImpl lock.

*** This issue has been marked as a duplicate of 61827 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo